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Welcome to the Introduction to EtherNet/IP Hands-On
Lab
About This Hands-On Lab
Welcome to the Introduction to EtherNet/IP lab. The IP in EtherNet/IP puts the “industrial” in
standard EtherNet/IP, allowing you to perform I/O control, device configuration, and data collection
on a single network. While going through this lab session, you will learn the easy and powerful
features of EtherNet/IP.
What You Will Accomplish In These Labs
As you complete the labs in this hands-on session, you will understand the followings:


How to configure a network



How to do analog I/O



How to do interlocking



How to use PanelView Plus 600



How to use PowerFlex Drives



How to use web server page for traffic monitoring



How to use EWEB module

Who Should Complete This Lab
This hands-on lab is intended for users wondering if EtherNet/IP could work for their application.
Knowledge of RSLogix 5000 and RSLinx would be helpful, but is not required.

Before You Begin
Before you begin this lab, please complete the following computer setup steps:
1. Close any applications that are running.
2. From the service tray in the lower right-hand corner of the computer desktop, right click on the
RSLinx icon

and click on Shutdown RSLinx.

3. Ensure that the RSI Service Directory
Shutdown RSLinx).

is shutdown as well (this should terminate when you

4. From the computer desktop, double-click on the Batch Files
5. Double-click on the Intro to EthernetIP.bat file

shortcut.
and follow the prompts.
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6. If the ControlLogix Processors are not already in Remote Program mode, use a keyswitch to
change them to Remote Program.
7. Review the physical EtherNet/IP demo box on your table (single box).

8. Review the EtherNet/IP network diagram for the demo box:
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9. Review the chart below for IP addresses you will use later in the lab:

Note that initially you will have a network consisting of 7 nodes on your table.

Document Conventions
Throughout this workbook, we have used the following conventions to help guide you through the
lab materials.
This style or symbol:

Indicates:

Words shown in bold italics (e.g.,
RSLogix 500 or OK)

Any item or button that you must click on, or a menu name from
which you must choose an option or command. This will be an
actual name of an item that you see on your screen or in an
example.

Words shown in Courier text,
enclosed in single quotes (e.g.,
'Controller1')

An item that you must type in the specified field. This is information
that you must supply based on your application (e.g., a variable).

 FYI

Note: When you type the text in the field, remember that you do
not need to type the quotes; simply type the words that are
contained within them (e.g., Controller1).

The text that is displayed as shown is
supplemental information regarding the lab
materials; it is not information that is required
reading in order for you to complete the lab
exercises but may provide you with helpful
hints that can make it easier for you to use this
product.

Note: If the mouse button is not specified in the text, you should click on the left mouse button.
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Reviewing the Application Story
This lab has been created mostly around the ControlLogix L63 processor in slot 3 of the chassis in
the upper left corner of the demo box. You may assume that most of your plant operations are
through the L63 controller which includes the discrete control, analog control, PowerFlex drive,
Electronic Operator Interface, and DeviceNet.
Your management decided to add a remote controller (L55) for process interlocking at a later
phase. Also, you decided to add a web interface module (EWEB) for providing easy access to
maintenance department and remotely located system integrators to diagnose, troubleshoot, and
predict maintenance issues on devices or machines in the plant.
If this was a real project, prior to this point you should have taken the following steps to install your
system:


All Rockwell Automation modules including EtherNet/IP interfaces are installed and powered up.



Control and network wiring are complete. Almost 90% of the start-up problems are due to either
wiring or network architecture related.



Your controllers are connected via EtherNet/IP network or other networks. You verified the
system status by looking at the LEDs of the controller and EtherNet/IP interfaces.



You are ready to configure the IP addresses and other network parameters for each EtherNet/IP
devices. There are several ways to configure an IP address, Rockwell BOOTP utility is just one
of them. Other tools are RSLinx software, RSLogix 5000 software, DHCP software and more. If
you want to learn how to use BOOTP, refer to Appendix-A.

To save time, all EtherNet/IP nodes have been pre-configured in this lab.
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Lab 1: Configuring the Computer to Communicate
to the PLC
In this lab, we will introduce you to the RSLinx communications software. In this lab you will:


Start RSLinx



Configure an EtherNet/IP driver

Launching RSLinx Communication Software and Configuring a Driver
RSLinx is the communication software that allows a PLC to communicate with your computer. We
must first configure how we want our computer to communicate with our PLC.
1. From the Windows start menu select Start > Programs > Rockwell Software > RSLinx >
RSLinx.
If this launches the software in the computer service tray (lower right corner of the computer
desktop), click on the RSLinx icon

to maximize the software.

2. Once RSLinx starts, from the toolbar menu select Communications > Configure Drivers as
shown below:
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3. When the Configure Drivers window appears, from the Available Driver Types pull-down
menu, locate and choose the EtherNet/IP Driver and then click the Add New button.

 FYI
In RSLinx you noticed 3 different Ethernet drivers listed: EtherNet/IP Driver,
Ethernet devices, and Remote Devices via Linx Gateway. In general, you should
use the new EtherNet/IP Driver. It will automatically scan for and find any
EtherNet/IP compatible devices on the network. A few older Rockwell EtherNet/IP
products cannot be found using this driver. The older drivers work with all Rockwell
EtherNet/IP products, but will only scan for IP addresses that you manually tell them
to search for. You can have combinations of drivers and/or multiple instances of
each type active in RSLinx at the same time if needed.
4. Accept the default name of AB_ETHIP-1 by clicking OK.

5. When the Configure Driver: AB_ETHIP-1 dialog appears, ensure that the Browse Local
Subnet radio button is checked and then click OK.

This is selecting where the EtherNet/IP modules reside. The software locates valid IP
addresses.
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6. Verify that the driver is RUNNING as shown below:

The driver is now available and you can select the EtherNet/IP port from Who Active in
RSLogix5000 programming software.
7. Close the Configure Drivers dialog box and click on the RSWho icon

.

The RSWho Window appears as shown below:
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8. Click on the + sign next to AB_ETHIP-1, EtherNet/IP.
This enables the EtherNet/IP driver in RSLinx to browse your network and identify the nodes in
your network. You should see the following IP addresses:

9. Close RSWho.
10. Close RSLinx.
This completes configuring your computer using the RSLinx EtherNet/IP driver.

Lab 1 Summary
Did you notice that you did not have to define any IP addresses in RSLinx? Isn’t this a cool
feature!?! Also, RSLinx is a great tool to check out your network during start-up.
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Lab 2: Adding FLEX I/O
About This Lab
The purpose of this lab is to add a 1794-AENT (FLEX adapter with an analog output module) to
your network, configure that node and control the analog meter on the I/O panel.
You will notice that two discrete I/O modules (1756-IB16D and 1756-OB16D) already
exist under the Parent ENBT module in your I/O configuration list. The discrete
input/output modules are required for controlling the push buttons on the I/O panel.
Also, the Child ENBT already exists in the I/O configuration list. You will be adding a
DeviceNet scanner to this Child ENBT in the DeviceNet lab.
In this lab you will:


Add an FLEX adapter (1794-AENT) and an analog output module(1794-OE4E) to the I/O tree in
RSLogix 5000



Configure the modules (I/O tags are automatically created when you add an I/O module to the
configuration tree)



Write Logic in the controller

Note that to save time you will not write any ladder code. The necessary ladder rungs are already
there in your project.

Launching a Project in RSLogix 5000 Programming Software
In this section of the lab, you will launch the RSLogix 5000 software, which will allow you to
program the project.

1. From the computer desktop, double-click on the Working Folder.
2. Double-click on the existing project called EIP_DEMO.ACD.
This will launch the project in RSLogix 5000. The Controller Organizer appears on the left side
of the RSLogix 5000 window, with a Controller folder called EIP_DEMO.
Notice that the locally configured modules: Parent ENBT (IP address = 192.168.1.2), discrete
input, and discrete output. These modules are required for using the push buttons in the I/O
panel. The Child ENBT (IP address= 192.168.1.3) has also been configured.
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If you want to learn how to add modules to I/O Configuration list, refer to Appendix
C at the end of this document.
3. Right click on the Child ENBT > Properties to view the configuration parameters such as IP
address, Slot number, etc.

.

4. Click on Cancel when you have finished reviewing the Module Properties.

Adding the1794-AENT adapter module to the I/O configuration list
1. From the Controller Organizer I/O Configuration folder, right click on the Parent 1756-ENBT
module, choose New Module, and then click on the 1794-AENT module as shown below:
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2. Click on OK.
3. When the Select Major Revision window appears, select Major Rev 2 as shown below and click
OK to accept your changes.

4. When the following dialog box appears, configure the 1794-AENT as shown below and then
click Finish.

If you want to learn more about Communication Formats, refer to Appendix B at the
end of this document.
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Adding a 1794-OE4 Module to AENT in RSLogix 5000 Project
1. From the Controller Organizer I/O Configuration folder, right click on the 1794-AENT and
choose New Module.
2. When the following window appears, select the 1794-OE4 module from the list and then click
OK.

3. When the Module Properties window appears, enter the parameters as follows and then click on
the Next button.
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4. The following screen shows the default RPI value of 50ms. Leave this value configured as
shown below:

5. Click on Next 3 times so that you see the following configuration screen:

6. Use the pull-down menu for Channel 0 to select a range of (0 to 10V)/(0 to 20ms) since we will
be using 0 to 10 VDC for the analog meter in the demo box.
7. Click on Finish.
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Adding Alias tags to the Controller
An alias tag lets you create one tag that represents another tag. Both tags share the same value.
When the value of one tag changes, the other tag changes its value as well.
Why we are using alias tag in this lab? As you have noticed, the ladder codes were written first,
and we used general tag names in the ladder logic.
The great advantages of alias tags are as follows:


For each I/O device, you can create a descriptive name that describes the device, such as
In_any_PB (Input signal from any push button) or Dout__lites (outputs to the illuminated
lamps). One can however, customize these tag names depending upon the type of applications.



Test your logic without the I/O connected



Later, when the I/O layouts are complete, add the I/O modules to the I/O configuration of the
controller.



Finally, convert the descriptive tags to aliases for their respective I/O connections.

In this section you will connect three descriptive tags in the controller scope to their respective I/O
points.
11. From the Controller Organizer, double-click on the Controller tags.

You will see the following descriptive tags:

The In_meter_up tag (input signal for forward movement of the meter) is for the upper right most
push button. Similarly, the In_meter_down tag (input signal for reverse movement of the meter) is
for the lower right most push button. The Out_meter tag is for analog output signal to the analog
meter.
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12. From the bottom of the Controller Tags window, click on the Edit Tags tab.

13. In the tag editor click in the Alias For column next to the In_meter_up tag and click on the
down arrow.
14. Select Local:1.I.Data, and finally select the bit 3 from the bit table as shown below:

15. In the tag editor click in the Alias For column next to the In_meter_down tag and click on the
down arrow.
16. Select Local:1.I.Data, and finally select the bit 7 from the bit table.
Bit 7 is being used for analog meter down/reverse movement.

17. Verify that the tag editor appears as follows:

18. In the tag editor click in the Alias For column next to the Out_meter tag and click on the down
arrow.
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19. Connect this tag to analog channel output MyFlexAEN:0:O.Ch0Data as shown below:

20. Verify that your I/O Configuration and Controller Tags appear as follows before moving on:

21. From the toolbar menu, select File > Save As.
22. Save your project under the same name (EIP_Demo) in directory c:\RSLogix 5000\Projects.
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Downloading and Testing the 1794-AENT AND 1794-OE4
1. Verify that your controller is in Remote Program mode by toggling the keyswitch to PROG then
back to REM.
2. From the toolbar menu, select Communications > WhoActive.
3. When the Who Active window appears, browse to the 1756-L63 processor as shown below and
then click Download.

4. Go into Remote Run mode on the processor by toggling the keyswitch to RUN then back to
REM.
5. From the Controller Organizer I/O Configuration folder, examine all modules.
There should be no yellow triangles visible on any of the modules. The Logix processor I/O
LED should be solid green. If you see yellow triangles, right-click on any yellow triangle and
then select the Connection tab to view status. If you need help, call a lab assistant.
The analog output module will drive the voltmeter (in the demo box).
You don’t have to write any ladder code. Ladder code for 1794-OE4 Analog Module already
exists in your Demo_Routine.

NOT-SP003E-EN-E
9/21/2004

Page 23 of 98

6. From the Controller Organizer, double-click on the Demo_Routine to open the ladder editor.

7. Notice the following 3 rungs of logic for the 1794-OE4 which drives the analog meter in the
demo box.

Verifying FLEX Ladder Logic
Your ControlLogix 5563 processor is already in Remote Run mode.
1. In the demo box I/O panel, press and hold the METER UP pushbutton to make the AO0 meter
goes up.
2. Press and hold the METER DOWN pushbutton to make the meter goes down.
3. If the meter does not go up or down, call a lab assistant.
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Lab 2 Summary
You learned how to add a FLEX adapter and an analog output module to the I/O list, and configure
them to operate an analog meter in the I/O panel.
You now have 1756 I/O, and FLEX I/O working! Congratulations!!
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Lab 3: Processor Interlocking
About This Lab
The purpose of this lab is to understand how to Produce a tag and Consume a tag. This method
enables you to interlock Logix processors without programming. Logix controllers can produce
(multicast) and consume (receive) system- shared tags that are sent and received via the
EtherNet/IP communication module.
A produced tag allows a PLC processor to produce a tag out on the wire for consumption by 1 or
more processors on the network. This is used most frequently for interlocking processors.
The controller (5563) in the Parent rack will Produce a tag. The controller (5555) in the Child rack
will Consume that tag. To produce a tag, you have to configure the produced tag in the RSLogix
5000 project for the 5563 controller. You have to also configure a consumed tag in the RSLogix
5000 project for the 5555 controller.

Network Diagram
IP=192.168.1.1

Ethernet Switch
Panelview 600 +
IP=192.168.1.5

Interlocking

1756-ENBT in Child rack
1756-ENBT in Parent rack
1756-L63 controller
IP=192.168.1.2

1756-L55 controller
IP=192.168.1.3
1756-ENBT Parent
IP=192.168.1.4

PF 70

NOT-SP003E-EN-E
9/21/2004

Page 26 of 98

Verifying EtherNet/IP Connectivity
1. From the toolbar menu in RSLogix 5000, select Communications > Go Offline.
2. Maximize RSLinx by clicking the RSLinx icon in the computer service tray.
3. From the toolbar menu, select Comunications > RSWho.
4. Navigate through the AB_ETHIP-1 driver to ensure that you find both the controllers, one in the
Parent rack and another in the Child rack.

5. When you have verified that your network appears as shown above, close RSWho and
minimize RSLinx.
Let us create a Produced tag in L63 controller now.

Creating a Produced Tag in L63 Controller
1. Back in RSLogix 5000, right-click on the Controller Tags folder and select Edit Tags.
2. Scroll to the bottom of the tag list, right click on the asterisk, and select Edit Tag Properties.
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3. When the Tag Properties window appears, enter the parameters as shown below:

4. Click on OK.
5. Verify that you see the Produce_tag in your controller’s tag list and then Save your work by
clicking on the Save

icon.

6. From the toolbar menu, select Communications > Who Active.
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7. When the Who Active window appears, select the 1756-L63 processor as shown below and
click Download.

8. When prompted, select Yes to place the controller into Remote Run.
9. Examine the list of modules in your I/O configuration list.
There will be no yellow triangles. At this point of time you will have a solid green I/O indication
on your controller.

10. Minimize this session of RSLogix 5000.
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Configuring the Consumer of the Produced Tag
In this lab, you will open another RSLogix 5000 project where you will configure the consumer of
the Produce_tag you created in the previous lab section.

1. From the computer desktop, double-click on the Working Folder.
2. Double-click on the existing project called Consumer55.ACD.
This will launch the project in RSLogix 5000.
RSLogix5000 is in Offline mode. Your I/O configuration and controller’s tag list look like the
following picture:

Adding a Remote Controller in the L55 Project (Defining the Producer)
You already have the Parent ENBT defined in your I/O configuration tree. In this section of the lab,
you will add a Controller (L63) under that.
Notice the digital input module in the configuration tree. We require this input module for using one
push button (DI0) on the IO panel.
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1. Right click on the Parent ENBT, click on New Module, and select 1756- L63 from the list of
available devices.

2. Click on OK, choose Major Revision 13 when prompted, and click on OK once again.
3. Enter the parameters as shown below, then click on Finish.
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4. Verify that EIP_Demo shows up under Parent ENBT in the I/O configuration list as shown
below:

Creating a Consumed Tag
Now, create a consumed tag in the controller named ConsumerL55.
1. In your Consumer55.ACD project, double-click on the Controller Tags and select the Edit
Tags tab at the bottom left corner of the Tags window.
2. Create a new tag named Consume_tag as shown below and then click in the white space
below the tag to accept your change.

3. Select the Consume_tag by clicking on the grey area to the left of the tag name.
This will select the entire record as shown below:

4. Right click on the record and select Edit Tag Properties.
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5. When the Tag Properties dialog box appears, ensure you’re on the General tab and fill in the
parameters as shown below:

6. Click on the Connection tab and configure the parameters as shown below:

7. Click on OK and verify that the newly created tag appears as follows:
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Saving and Downloading the Consumer Project
1. Save your project.
2. From the toolbar menu, select Communication > Who Active.
3. Navigate through the Child node (IP address = 192.168.1.3) to select 1756-L55 controller as
shown below:

4. Click on the Download button.
5. When the following screen appears, click Download once again.

6. Change the controller mode back to Remote Run mode.
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7. Verify that your Consumer55 project has all steady green LEDs and no yellow triangles as
shown below:

Initializing the Produced Tag
1. Verify that both the controllers L63 and L55 are in Remote Run mode.
2. In the EIP_Demo.ACD (producer) project, double-click on Controller Tags and ensure you’re
in Monitor Tags mode.
3. Locate the Produce_tag you created earlier in the lab exercise.

4. Initialize the 2 DINTs to some non-zero values such as 11, 111 as shown above.
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Testing the Produced and Consumed Tags
1. In the Consumer55.ACD project, double-click on Controller Tags and ensure that you are in
Monitor tags mode.
2. Locate the Consume_tag you just created and verify that the tag values (e.g., 11, 111) are the
same as being produced.

3. To prove that the tags are being consumed, the students should left-click on either of the
consumed tags and set the value to 0. The tag should immediately change back to the nonzero value (11).
4. Save your work.
5. In both projects, from the toolbar menu, select Communications > Go Offline.
6. In both projects, from the toolbar menu in both projects, choose File > Close.

Lab 3 Summary


Did you like the data exchange method using Produced tag and Consumed tag?



You did not write any ladder code for exchanging data.



Did you notice that the consumption rate is defined in the Consume tag!!
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Lab 4: Using RSView ME and PanelView Plus 600
About This Lab
This lab will provide a demonstration of EtherNet/IP communications to a PanelView Plus 600. The
programs for the PanelView Plus 600 and the ControlLogix processor have already been
constructed. The ControlLogix program was created using RSLogix 5000. The PanelView Plus
600 program was created using RSView Studio. We will use a PanelView Plus 600 Touch screen.

Downloading to the 5563 Processor
1. From the RSLogix 5000 toolbar menu, select File > Open.
2. Open the program named EIP_DEMO_PVP.ACD.
3. Download this program to the L63 processor in slot 3 of the upper chassis of your lab station
(IP address 192.168.1.2) and go into Remote Run mode.
4. From the toolbar menu, select Communications > Go Offline.
5. From the toolbar menu, select File > Exit.

Opening the Existing RSView ME Project

1. From the computer desktop, double-click on the RSView Studio icon

2. Select

.

and click on Continue.

3. When the following list appears, select the EIP_DM application as shown below and then click
Open.
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This will launch the development environment for RSView Studio as shown below:

.

Reviewing the HMI Communications Path
An application display screen has already been created for this lab. What needs to be configured is
the path to the controller tags that will be displayed on the PanelView Plus 600.
1. Expand the RSLinx Enterprise icon in the tree and double-click on the Communications Setup.

This will display the communications setup window.
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2. Verify that the communication shortcut EIP has already been created.

3. Click on the Local and Target tabs and verify that the communication path is directed to the
1756-L63 in slot 3 as shown above.
4. Select OK to close the Communications Setup window.

Creating and Downloading a Runtime Application
Now that the configuration is complete, the runtime application must be created.
1. From the toolbar menu, select Application > Create Runtime Application.
2. Type the filename ‘EIP_DM.mer’ and select Save.
Please be patient as the runtime image is created.
3. To download this image, select Tools > Transfer Utility from the toolbar menu.
4. Use the Browse key to select the file you just created.
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5. Select the PanelView Plus 600 (IP Address 192.168.1.5) for the Destination Terminal and
select Download.
6. If asked if you want to overwrite the existing file, select Yes.

7. Once the download completes, select OK and exit the transfer utility.
The application has been downloaded to the PanelView Plus 600.
8. Go to your PanelView Plus 600 screen. The RSView Station window should be displayed.
9. Load the image that was downloaded by selecting Load Application.
10. Choose the file that was downloaded (EIP_Demo.mer) and select Load.
11. Select Yes to replace the current configuration. It will take a few moments to load.
12. Once loaded, select Run Application.
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13. The following screen will appear that looks similar to the demo box push buttons and gauge:

.

14. In RSView Studio, select File > Exit from the toolbar menu.

 FYI
While online in RSLogix5000, note that the PanelView Plus 600 does not appear in
the I/O Configuration of the ControlLogix processor. In this demonstration, the
PanelView Plus 600 is initiating the transfer of information (explicit messaging). So,
the PanelView Plus 600 is not in the list.
The RSLogix5000 program downloaded includes all functionality that you have
observed through the completion of the previous labs. It also includes ladder logic
that will provide parallel functionality for the PanelView Plus 600.

Confirming the PanelView Plus 600 Operation
Test the PanelView Plus 600 by doing the following:
1. On the PanelView Plus 600 screen, press and hold the DI03 button.
The analog meter should start the move to the right.
2. On the PanelView Plus 600 screen, press and hold the DI07 button.
The analog meter should start the move to the left.
3. Press the real pushbuttons on the demo box.
Note the resultant action of the outputs and the analog meter on your PanelView Plus 600. It
has been designed to mimic the same operation.
4. Press the pushbuttons on the PanelView Plus 600 screen and observe how the results on the
hardwired I/O and the screen are the same (reference the LEDs 1756-IB16D and 1756-OB16D
in slots 1 and 2 of the top chassis).
5. When you have finished exercising the PV+ 600, press the Goto Config button on the screen to
return to the RSView ME Station.
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6. From the Main Menu, select Terminal Settings > File Management > Delete Files > Delete
Applications.
7. Select the file you downloaded and press the Delete button.
8. When finished, continue to press the Close button until you reach the Main Menu.

Lab 4 Summary
What you learned from this lab:


Applications can be developed for the PanelView Plus 600 that can monitor tags within a
controller as well as modify the tags via the touch screen.



You can create a PanelView Plus 600 application and download it over EtherNet/IP to the
PanelView Plus 600 device.
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Lab 5: Add Remote I/O on DeviceNet
About This Lab
The purpose of this lab is to demonstrate access to a remote DeviceNet I/O over EtherNet/IP. By
adding a 1756-DNB in your Child (remote) chassis, you will verify that the DeviceNet photoeye (in
the demo box) can control the discrete output lights in the demo box.

Add 1756-DNB to RSLogix5000 Project

1. From the computer desktop, double-click on the Working Folder.
2. Double-click on EIP_Demo.ACD to launch the project in RSLogix 5000.
3. From the I/O Configuration folder in the Controller Organizer, right click on the Child 1756ENBT and select New Module.
4. When the Select Module Type window appears, select the 1756-DNB and click OK.

5. When prompted, choose Major Revision 4 and select OK to accept your changes.
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6. When the Module Properties dialog box appears, enter the parameters as shown below:

The Input Size is 1 because the photoeye has only 1 byte of input data, so single DINT is
adequate. The Status Size of 32 is the default size provided by the DNB and RSLogix5000.
7. Click on Next and change the RPI to 10 ms as follows and then click on Finish.

NOT-SP003E-EN-E
9/21/2004

Page 44 of 98

Connecting Alias tags to their I/O Points
1. From the Controller Organizer, double-click on Controller Tags.
You still have two descriptive tags which are not connected to their I/O points:


In_photo tag is an input tag to the 1756-DNB



Out_DNB_Run tag is for the Command Register Run mode bit

2. In the tag editor, click in the Alias For column next to the In_photo tag. Then click on the down
arrow. When the tag browser opens, double-click on Child3:I.Data[0] as shown below:

3. Verify that your tag editor now appears as follows:

4. Repeat step 2 above for the tag Out_DNB_Run and connect it to the
Child:3:O.CommandRegister.Run by clicking on the + sign next to
Child:3:O.CommandRegister and choosing the Run bit from the pre-defined structure.

5. From the toolbar menu, select Communications > Download and download to the L63
ControlLogix controller in slot 3 of the top chassis.
6. Go into Remote Run mode.
7. Verify that all modules in the I/O list do not have yellow triangles on any modules in the I/O
Configuration.
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If you have a yellow triangle(s), click on the module and select the Connection tab to view the
status and call a lab assistant for help.

Reviewing the Ladder Logic for the DNB
1. From the Controller Organizer, double-click on Demo_Routine under the Main Task.
This will launch the ladder editor where you can view and edit ladder logic.
2. Review rungs 1 and 2.
Rung 1 puts the DNB in Run mode. Rung 2 writes data to the output LEDs on the demo box
when you place an object in from of the photoeye.Look at the rungs.

Photo eye senses object in front of it

3. Verify that the LED display on the DNB indicates RUN mode.
4. If all LEDs in the demo box are on, press any push button on the panel to switch off the lights
except the light you press.
5. Now, put your hand in front of the photoeye switch and verify that all the LEDs illuminate.

Lab 5 Summary
We demonstrated the access to a remote DeviceNet I/O over EtherNet/IP. This is how DeviceNet
equipment at the plant floor level communicates with the remote Controller over EthernNet/IP.
Optional Lab Exercise: If you wish to learn more about creating a scanlist for the
1756-DNB, go to Appendix D.
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Lab 6: Adding a PowerFlex70 drive
About This Lab
The purpose of this lab is to add a PowerFlex70 drive to your network, configure that node and
control it over EtherNet/IP. The PowerFlex 70 demo box is a stand alone device. Ensure that the
drive is physically connected to the switch located in the EIP demo box and single phase A/C power
is available to the drive.
If you want to learn about Drive Explorer for configuring and monitoring drive
parameters, go to Appendix E. Drive Explorer is RSLogix5000 independent tool,
which comes free with the drive.

Adding the PowerFlex70 Drive to the I/O Configuration
1. From the toolbar menu, select Communications > Go Offline.
2. In the I/O Configuration folder, right click on the Parent 1756-ENBT and choose New Module.
3. When the list of available devices appears, select the PowerFlex 70E as shown below and click
OK to accept your change.
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4. When the following window appears, select Major Revision 2 as shown below and click OK.

5. When the Module Properties window appears, configure the PowerFlex 70E drives as follows:

 FYI
Datalinks
A Datalink is a type of pointer used by PowerFlex drives to transfer data to and from
the controller. Datalinks allow specified parameter value(s) to be accessed or
changed without using explicit messages. When enabled, each Datalink consumes
either four bytes or eight bytes in both input and output image table of the controller.
The drive determines the size of Datalinks.
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6. Click the Next button.
7. Leave the Requested Packet Interval set at the default value of 5 ms as shown below and click
on Finish.

 FYI
Requested Packet Interval (RPI)
In the RPI value determines the maximum interval that a controller would move data
to and from the adapter. To conserve bandwidth, it is wiser to use higher values with
the lower priority devices
8. Verify that the PowerFlex 70E drive is now listed to the I/O configuration as shown below:
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Viewing the Pre-Defined Data Structure for the PowerFlex 70E
1. From the Controller Organizer, double-click on Controller Tags.

.

2. Change the scope from Main_Routine to EIP_Demo (controller).

3. Locate and expand the PF_70:I data structure to view the tags that were automatically created
when you added the PowerFlex 70 E drive to the I/O Configuration.
Notice that the tag names correlate to the Logic Status bits and Feedback word. These
status/feedback bits can be used in the ladder code for monitoring your drive status.

NOT-SP003E-EN-E
9/21/2004

Page 50 of 98

4. Locate and expand the PF_70:O data structure to view Logic Command Bits and Reference
word, which were created automatically by adding the PowerFlex 70E to the I/O Configuration.

We will use an extra step to add few alias tags. In the Flex IO lab you have already used alias tags
and you are aware of its advantages.

Creating Alias Tags for Use with the PowerFlex 70 Drive
In order to save time in the lab, the controller tags and the ladder program already exist in the
Main_Routine. You have to associate the alias tags to its actual I/O addresses. Let us look at the
Controller tags first. These are the logic command tags being used for operating various drive
functions. You will be using these bits in the ladder code to operate the drive.
1. From the Controller Organizer, locate the tag Start Command.
2. Click on the Alias For column next to the tag Start Command, browse through the tag list
under PF_70:O, and double-click on PF_70:O.Start as shown below:
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3. Left click to accept the tag change.
4. Verify that the tag now appears as follows:

5. Use this same procedure to alias the following tags:


Stop_Command > PF_70:O.Stop



Reverse_Command > PF_70:O.Reverse



Jog_Command > PF_70:O.Jog



Forward Command > PF_70:O.Forward



ClearFault_Command > PF_70:O.ClearFault

6. When you have finished aliasing the tags into the PowerFlex 70E data structure, the controller
tag editor should appear as follows:
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Downloading the RSLogix 5000 Project and Verifying Successful
Communication
1. From the toolbar menu, select Communications > Who Active.
2. When the Who Active window appears, browse to the 1756-L63 processor as shown below and
then click Download.

3. Go into Remote Run mode on the processor by toggling the keyswitch to RUN then back to
REM.
4. Verify that your I/O Configuration appears as shown below (no yellow triangles should be
visible).
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5. On the controller faceplate, verify that the I/O OK LED is solid green as shown below:

6. On the PowerFlex drive (20-COMM-D), the PORT, MOD and NET A LED’s should also be solid
green. Now you are ready to start and stop the drive.

Reviewing the Ladder Code and Operating the Drive
This section demonstrates PowerFlex70 operation.
1. From the Controller Organizer, double-click on Demo_Routine to open the routine in the ladder
editor.

2. Review rungs 6 – 10 which are meant for operating the drive. The respective output bits are
called Logic Command Bits.

NOT-SP003E-EN-E
9/21/2004

Page 54 of 98

3. Right click on the Start and select Toggle Bit to energize this tag.
The drive will start running in the forward direction.
4. Right click on the Start again and select Toggle Bit to de-energize this tag.
Notice that the drive started on an OFF > ON transition of the Start_Command and will continue
to run until a Stop_Command is initiated.
5. Right click on the Stop and select Toggle Bit to energize this tag.
The STS LED on the PowerFlex 70 will flash yellow to indicate that a Stop command has been
initiated. The drive will stop.
6. Right-click on the Stop again and select Toggle Bit to de-energize this tag.
The yellow flashing changes to green flashing.
Try this same procedure for the direction (Forward and Reverse) bits:
7. Toggle the Reverse bit on. Notice that the drive motor doesn’t move; you must now enable the
drive by toggling the Jog bit.
8. Toggle the Jog bit off and try the same thing with the Forward bit.
9. When finished exercising the drive, ensure that all bits are de-energized.

Changing the Speed Reference
In real life application, the commanded frequency (Hz) value entered in floating point format (xx.xx)
is converted to engineering units before delivering that to the drive as speed reference. The drive
will accelerate or decelerate to the command provided Start_Command is initiated.
To keep it simple, we will avoid the scaling part, and directly manipulate the speed reference value
from the Controller Tags
1. Make sure that the drive motor is not running.
2. From the Controller Organizer, double-click on the Controller Tags.
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3. Expand the PF_70:O data structure to view the PF_70:O.CommandedFreq tag as shown
below:

You can enter any values between 0 – 32, 767. The PowerFlex drive’s default Maximum frequency
is 130 Hz. Once you have set a value for the CommandFrequency tag, and started the drive from
the ladder code, you can monitor the frequency of the drive from its front panel.
4. If the STS Led on the front of the drive is red (indicating a fault), enter a 1 into the ClearFault
tag and press Enter; then clear the tag by entering a 0.
5. Change the value for the Command Frequency and then press Enter.
Notice that the drive motor is not spinning.
6. Enter a value of 1 in the PF70:O.Start tag.
The drive should start to turn the motor at the commanded frequency.
7. Enter a value of 0 in the PF70:O.Start tag and a value of 1 in the PF70:O.Stop tag.
8. Verify that the motor slows to a stop before proceeding.
9. Minimize your RSLogix 5000 session.

Lab 6 Summary
You learned how easy it is to add a PowerFlex70 drive to the I/O list, configure the drive, and
operate it on EtherNet/IP.
Optional Lab Exercise: If you wish to learn more about Drive Explorer, an
independent tool that can be used to configure and monitor PowerFlex drives, go to
Appendix E.

NOT-SP003E-EN-E
9/21/2004

Page 56 of 98

Lab 7: Web Server and Traffic Monitoring
About this Lab
In this lab, you will learn how to use web diagnostic pages to check out the health of your network
system, including both connections and I/O messages (Packets). You will view the CPU utilization
counter and also learn how to compare the RPI (Requested Packet Interval) and API (Actual Packet
Interval).

Start Web Browser
The following labs refer to Internet Explorer but you can use either Internet Explorer or Netscape.
You are working with L63 controller.
1. From the computer desktop, double-click on the Internet Explorer icon.
2. Enter the IP address ‘http://192.168.1.2’ in the browser’s address field.
The following page appears:

You are now viewing web page diagnostic information for the 1756-ENBT in the top chassis of the
demo box.
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3. From the menu on the left, expand the Diagnostics folder.

4. Click on Diagnostic Overview.
The following screen appears:
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 FYI
Reference the window on the previous page to review the following information:
Ethernet Link
Speed - The module is passing data over the EtherNet/IP network. Rockwell
Automation EtherNet/IP interface modules support both 10Mbps and 100Mbps
speeds.
Duplex - The mode of communication module, full-duplex meaning transmission and
reception of data simultaneously. Half-duplex means either transmission or reception
of data.
Auto negotiate Status – Rockwell Automation EtherNet/IP interface modules auto
negotiate with the switch for the 100 Mbps and full – duplex mode.
System Resource Utilization (CPU)
This is an indicator of how loaded is your EtherNet/IP interface module at any point
of time.
CIP Connection Statistics
Common Information Protocol (CIP) based connections are used for I/O controls and
produce – consume tags.
I/O Packet / Second Statistics
Actual class1 packets per second the module is currently receiving and transmitting
over EtherNet/IP network. Actually, using a simple formula, you can calculate the
number of packets / sec
Packets per second = [C * 2] / RPI
Where:
RPI = Requested Packet Intervals i.e data update rate
C = Number of connections
For example, analog output module in the AENT adapter is a single Direct
Connection (C=1) and it is using a RPI of 50 msec. Therefore, using the above
formula,
Packets per second = [1*2] / 0.050 = 40. Can you verify this with the AENT module’s
web server page!
Sent – This field represents number of class1 packets sent each second to the
controller
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Receive – This field represents number of class1 packets received each second from
the controller
Capacity – Each ENBT module is capable of handling 5000 packets / sec. Each
AENT module can handle 9500 packets / sec.
Actual Reserve = Packet capacity (5000 or 9500 – Actual class1 packets per sec)
TCP Connections
TCP connections are meant for EtherNet/IP communication. An EtherNet/IP interface
device uses TCP connection for each IP address to which the device is connected.
Multiple CIP connections can go through a TCP connection. For example TCP
connections are:


HMI (Human Machine Interface) to a controller that supports EtherNet/IP



Logix MSG instruction to a controller



OPC or DDE accessing a controller



Produce-Consume tag

5. Click on Network Setting.
The following screen appears:

6. Review the details under Network Interface and Ethernet Link.
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7. Click on Message Connection.

Message Connection tells you about the explicit message related connections or connections for
non – I/O control. For example, the above connection is between your computer running
RSLogix5000 and L63 (IP address 192.168.1.2). This is also called as ‘Class 3 type connection’.
8. Click on the I/O Connections.

I/O Connections (also known as Class 1connections) are used for the most time critical data for
I/O and produce – consume tags. Notice the Source and Destination addresses in the above
picture.
RPI (Requested Packet Interval) is the update rate specified for a particular piece of data on the
network. RPI can be defined for an entire rack or for a specific module. Notice the various RPIs
above for different modules and rack.
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9. Click on the Ethernet Statistics.
The following screen appears:

10. Take some time to review the different types of errors under Media Counters.
11. When finished, close Internet Explorer by clicking on File > Close from the toolbar menu.

Lab 7 Summary
What should you remember from this lab?
The packets/second capacity of 1756-ENBT is 5000.
The packets/second capacity of 1794- AENT is 9500.
Did you find the web server page helpful for monitoring and troubleshooting your EtherNet/IP
network? Isn’t this a great tool to diagnose the health of your network and performance of the
individual EtherNet/IP interfaces?

Extra Task
For the Flex adapter module (1794-AENT), can you change Packets/Sec from 40 to 200?
Answer:


Packets /sec = (Connection * 2)/ RPI, RPI was 50 msec.



New RPI = C * 2 / (Packets/sec) = 2 / 200 = 10 msec



Therefore, change the RPI from 50 msec to 10 msec, packets /sec would be 200.



How would you verify that? Answer: Check with the AENT web server page (IP = 192.168.1.4).
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Lab 8: Reviewing Features of the EWEB Module- More
than Web services
About this Lab
In this lab we will explore the 1756-EWEB module. You are a production supervisor of Lacme Tool
and Machine Company. Upper management has asked for easier access to production statistics in
their office. You’ve been manually publishing them once a day and it’s been quite a pain. Now
management says they want statistics at the end of each shift. Your task here will be to implement
a web interface to allow access to production data from anyone who asks for permissions through
your company intranet.
Your Objectives as a Production Manager


Make it simple for upper management to get production related data without your assistance
from any office location to any plant location into the business system.



Provide easy access to maintenance department and remotely located system integrators to
diagnose, troubleshoot, and predict maintenance issues on devices or machines in the plant.

Key Topics Covered in this Lab


Routing and Explicit Messaging (no I/O)



Creating and Using Data Views (convenient off-site access to control data)



Sending Emails



Modifying and Downloading Web Pages



Data Collection with XML

Background
The EWEB module allows the user to host web pages from the ControlLogix rack. This enables
Lacme’s employees to view data from their control systems on any computer using Internet
browser. (If the viewing computer is outside of the company network, the user will have to bridge
the firewall). The EWEB also offers storing space for user documentation and help files. It offers
5.5MB worth of storage memory. Lacme is especially interested in remotely accessing its machines
in the field and potentially correct problems without traveling to the site.

Opening an Existing RSLogix 5000 Project and Downloading to the
ControlLogix Processor

1. From the computer desktop, double-click on the Working Folder.
2. Double-click on the existing project called Consumer55.ACD.
3. From the toolbar menu, select Communications > Who Active and download the project to the
ControlLogix L55 processor in slot 0 of the bottom chassis.
4. Go Online with the processor and go into Remote Run mode.
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5. Minimize the RSLogix 5000 project.
Notice the 1756-EWEB is in slot 2. The IP address of the EWEB module is
192.168.1.6. You can also download the project using the EWEB module. The 1756EWEB has all of the CIP Explicit Messaging capabilities of the 1756-ENBT. It can do
everything the 1756-ENBT can do, except controlling I/O.

Accessing the 1756-EWEB
1. From the computer desktop, double-click on Internet Explorer

.

2. In the address field type ‘http://192.168.1.6’ and press Enter.
This is the IP address of the EWEB module in slot 2 and will open the default EWEB web page
as shown below:

3. From the menu on the left side of the web page, select Administrative Settings > User
Management > Edit Users as shown below:
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4. When the login screen appears, enter the following User Name and click OK.

NOTE: This is the out-of-the-box login account. The password would need to be changed in any
application that requires security. You are now on the Edit Users page. This is where you would set
up an account to differentiate the amount of access to EWEB functionality by various users. We will
use the default administrator’s account. Access could be three types:


Read: read only access to tags in the Data Views;



Write: write and read access to tags in the Data Views;



Administrator: complete access to all Web server functionality;

Creating and Using Data Views (and Remote Custom Data Monitor)
1. From the menu on the left side of the web page, select Data Views > Data Views.
2. Click the New Data View tab at the top of the right-hand screen.

3. Fill out all the fields as shown below and then click on the Add icon (this will add the tag to a
new data view).
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MyDint is a tag that resides in the Consumer.ACD project running the L55 controller.
4. Name the Data View as MyView and then click the Create View button.

Note: A data view may contain more than one tag of various types. Once the data view is
created, you can see a list of all the data views.
5. Click on the Data Views tab.
6. Click on MyView.XML link under View Filename to see the data view you just created.
The following screen appears:

The EWEB module data views cannot retrieve data directly from I/O. If we wish to
access this data, we must reference the data through an alias tag in the controller.

Writing Data to the L55 Processor from the EWEB Module
In addition to reading data from the Logix controller, the EWEB can also write data to the controller
for diagnostics and limited troubleshooting.
1. Change the number in the Value window and click on the Update button.
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2. Maximize the RSlogix 5000 project so you can verify the change you just made.
3. Double-click on Controller Tags and click on the Monitor Tags tab.

4. Locate the MyDint tag and verify that the value of the tag changed to reflect what you entered in
the EWEB module.
5. Minimize the RSLogix 5000 project.

Setting up the EWEB to Send Emails
For this lab we have installed SMTP mail server software on your computer. Typically this server
would be provided and running from your office IT staff.
1. From the computer desktop, double-click on the ArGoSoft Mail Server Icon.
2. From the menu on the EWEB module web page, click Administrative Settings > Device
Configuration > Email Configuration.
Your computer is the SMTP mail server for this lab.
3. Ensure that your computer’s IP address is in the line for SMTP server (192.168.1.1), the SMTP
Authentication checkbox is empty, and then click Apply Changes.
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SMTP Authentication is usually used with servers on the Internet, so only
authorized users are allowed to "relay" mail through them. In this case, the ability to
use the server successfully is based on authentication, and not at all on IP address.
The idea is to prevent spammers from misusing email server on the Internet.

Sending Controller Generated Emails
The EWEB has an email interface that is good for testing the mail server and may, from time to
time, prevent a user from having to open a separate email client. However, the greatest benefit of
the embedded email client is that it allows the control system to send email messages.
1. Maximize the RSLogix 5000 project and ensure that you are Online with the controller.
In the file, there are three tags that we will be using to send an email message. Email is sent
using the MSG instruction, and there are three tags that we will be using to send a message:


email_text tag will contain our email message



email_status tag will serve as a buffer for any status information returned by the MSG
instruction



email_message tag controls the message (MSG) instruction.

The email_text and email_status tags are of the pre-defined STRING type with a maximum
length of 82 characters. This presents a problem since an email message can easily exceed 82
characters. However, the content of email messages sent from the controller to the EWEB may
not exceed 474 characters (The message instruction must attach four characters as overhead
making the maximum message length 478 characters). We, therefore, have aliased to strings
of a user-defined string type with a maximum length of 474 characters.
2. In the Tag Editor, click on the Edit Tags tab.
3. Notice that the aliased_email_status tag is the alias for the email_status tag. Similarly,
aliased_email_text has been entered in the Alias For column for the email_text tag.

4. Click on the Monitor Tags tab at the lower left corner of the tag editor.
5. Click on the Value column for the email_text tag.
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6. Click on the ellipsis
controller:

and review the text in the string browser that will be emailed from the

7. Click Cancel when you have finished reviewing the string information.
8. From the Controller Organizer, double-click on the MainRoutine to open the ladder editor.
The following rungs of code appear:

9. Open the Message Configuration dialog by clicking the ellipsis
instruction.

button in the MSG
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10. Ensure all fields of the Configuration tab appear as shown below:

11. Click on the Communication tab and ensure that the path appears as ‘1,2’.
12. Click on Apply and OK to accept your changes.
Examining the path, the ‘1’ tells us to go to the back plane from the controller, and
the ‘2’ tells us to go to the EWEB module in slot 2.
13. Press the DIO button on the demo box.
This should send an email message from the controller to the computer.
14. Minimize the RSLogix 5000 project.
15. From the computer desktop, double-click on MS Outlook Express.
16. Double-click on the Inbox and verify that you received incoming email.
You should see the message you sent from the controller. This could also just as easily gone to
a text pager or cell phone with text paging capability.
17. Delete all email messages in the inbox and then Exit MS Outlook Express.
18. Turn off the ArgoSoft Mail Server by right clicking on the icon in the computer service tray and
choosing Exit.
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Modifying and Downloading Web Pages
Management is thrilled with the new web interface and their ability to gather this data up to at will.
In fact, your supervisor has been using it very extensively and has an issue with third shift
production. It appears to fall off significantly over the other shifts. You get the new intern in the
department to put together a web page so you can get even more data in a much easier to readable
format.
We will be using FTP to move files from your computer to the EWEB module. FTP stands for File
Transport Protocol, and it is a standard technology, used for managing files on remote servers.
1. In the browser’s address bar, type ‘ftp://administrator@192.168.1.6’ which is the IP address
for your EWEB module.

 FYI
The password is transmitted over the network in plain text, so it is visible
to anyone using a network Sniffer. It is recommended that you create a
temporary Administrator account for when you use FTP to access the web
server module. Also, leave FTP disabled except for when actively copying
files to or from the web server module.

2. From the computer desktop, double-click on the Working Folder.
3. Copy the data.asp and main.html files and Paste them in the Internet Explorer window you
just opened for FTP use.
This will transfer them to the EWEB.
Let’s look at the web page we downloaded.
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4.

In the browser’s address bar, type ‘192.168.1.6/user/web/main.html’.
The following screen appears:

5. Browse the different links on the web page to see if you can figure out why production on Line 7
is so low. Please be patient as the live camera images may take a minute to load.
6. Close Internet Explorer.

Data Collection through XML
One of the great benefits of the EWEB module is that it Queries and stores data in XML, a widely
supported, platform independent file format. In this section, you will see some examples of how we
can extract data from our XML data views. Let’s see how management can easily pull this data
from DataView on our web interface into an excel spreadsheet that gets fresh data on command.
1. Launch MS Excel.
2. From the toolbar menu, select Data > XML > Import.
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3. In the File Name field, enter ‘http:// 192.168.1.6/user/system/dataviews/ProductionData.xml’
as shown below:

4. Click the Import button.
5. If the Login screen appears, enter a User Name of Administrator and click Enter.
6. When the following window appears, click OK.

7. If prompted to enable macros, say Yes.
The excel sheet now collects live data as defined from the data view. Okay, this is sort of a
success but the data is ugly with lots of fields that your management doesn’t want to see. Lets
customize this XML data in excel so that only the relevant production data is displayed.
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8. From the toolbar menu, select Data > XML > XML Source.
This provides a dialog to allow you to select which XML data fields you want and don’t want in
your excel data sheet.

9. Highlight all the data columns we just imported into the excel sheet and right click select Delete
so the spread sheet is empty again.
10. Now drag elements from the XML Source dialog that you want displayed on your screen (we
dragged Name, Path, and ns1: value on to our sheet below):

11. Now with one of the items you just dragged to the screen selected, from the toolbar menu select
Data > XML > Refresh XML Data.
The data you requested should be updated on your excel spread sheet.
Now to generate shift reports, all that needs to be done is this excel spread sheet opened, the data
refreshed and whatever excel functions need to be performed on the data can take place.
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Lab 8 Summary
In this lab, you explored the following features of the EWEB Module:


Easy and simple access to plant floor data using Data Views



Routing and Explicit Messaging (no I/O)



Sending Emails



Modifying and Downloading Web Pages



Data Collection with XML
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Appendix A: Adding Devices to the Network
This Appendix if for informational purposes only and should not be treated as part of the lab
exercise.
Read this document to learn “what” BOOTP is and “how” it works. All the Rockwell Automation
EtherNet/IP nodes have been configured using this tool.
The IP addresses used in this lab are part of standard TCP / IP EtherNet/IP.
What is BOOTP?
In order for a host to exchange data with other hosts, each host must have its own
distinct IP address. BOOTP is a simple way to provide IP addresses to hosts.
BOOTP uses IP to provide IP configuration and boot service, hence the name
BOOTP, for bootstrapping protocol. The requesting host sends a BOOTP request,
which is answered by a BOOTP server that has a configuration for the requesting
station.
The way of assigning IP addresses varies depending upon the product. All the devices will be
configured using a method called BOOTP as default.
The table below describes different ways of configuring IP addresses:
Devices

Default

1756-ENBT

BOOTP



BOOTP



RS232 through the 5555 / 5563
using RSLogix5000



ControlNet (CNB)
Using RSLinx Gateway functionality
or RSLogix5000



DH+
Using RSLinx Gateway functionality
or RSLogix5000



EtherNet/IP

Using RSLinx Gateway functionality or
RSLogix5000 (through another, already
configured, 1756-ENBT module in the same
chassis as the un- initialized ENBT module).
PanelView Plus 600

BOOTP

DHCP / Manually from touch screen

1794-AENT

BOOTP

BOOTP / RSLinx Gateway

PowerFlex70 Drive

BOOTP

DriveExplorer / PF70 HIM / Drive Executive
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This method requires a computer to examine the list of hardware addresses for the devices
connected to your network and assign corresponding IP addresses to them.
General procedure:

First, verify that your Rockwell EtherNet/IP nodes are not configured:


1756-ENBT modules (2)



The OK LED is blinking green, the NET LED is OFF, and the MAC address is being displayed
on the module.



1794-AENT



The Network Status LED is off (not illuminated), and the Module status LED is blinking green.



There are several tools to configure PowerFlex 70 drive:



PoweFlex HIM, BOOTP Server, DriveExplorer (Version 2.01 or higher) software, Drive
Executive (Version 1.01 or higher).



Panel View Plus 600

See touch screen Terminal setting on the RSView ME Station. Select Networks and
Communication, then Network Connections, then Network Adapters, and finally select IP address.
Check for the absence of IP address, and that DHCP OK is enabled. Also, in this screen, you can
see the EtherNet/IP hardware address.
1. For each of your RA EtherNet/IP nodes, record the EtherNet/IP hardware address below (the
labels are located on each device or PanelView Plus 600 setup screen):
1756-ENBT (in 5563
chassis)
1756-ENBT (in 5555
chassis)
1794-AENT
PanelView Plus 600
1756-EWEB
PowerFlex70

MAC Addresses
00 00 BC __ __ __

IP adddresses
192.168.1.2

00 00 BC __ __ __

192.168.1.3

00 00 BC __ __ __
00 00 BC __ __ __
00 00BC __ __ __
00 00 BC __ __ __

192.168.1.4
192.168.1.5
192.168.1.6
192.168.1.7

2. On your desktop, double-click the BOOTP Server application.

.
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As shown below, the Address Relationship windows should both be empty. The Request History
may be empty or have boot requests in it.

3. From the Tools menu, choose Network Settings.
4. When the Network Settings dialog appears, enter the following:

This convenience will keep you from entering the same mask and gateway for each of the IP
addresses you are about to assign.
5. Click on OK.
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When BOOTP server software is open, any “BOOTP enabled” module will show up in the
Request History as shown below. Here is an example:

6. Double-click on the MAC address.
The New Entry dialog appears.

7. Enter your desired IP address.
In this case, we are using ‘192.168.1.2’…the Parent ENBT
8. Click on OK.
We are not using DNS (Domain Name Service) in this lab. We will be using IP addresses
instead.
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DNS provides the function of translating the IP address of a host / node into
meaningful human understandable names. DNS uses a tree-like naming structure to
provide a naming hierarchy.

The newly entered IP address appears in the Relation List. This allows the BOOTP server to
configure that module the next time it receives a BOOTP request. Wait until the next request is
received (in the Request History window) from the module confirming the IP address was
assigned to it.
9. Select the IP address from the Relation List and click on Disable BOOTP/DHCP; the status
changes to “Command Successful.” This enables the EtherNet/IP interface devices to retain
their IP addresses.

10. Repeat the steps above for the remaining nodes


1756-ENBT in the remote chassis (child)
NOT-SP003E-EN-E
9/21/2004

Page 80 of 98



1794-AENT FLEX adapter



PowerFlex 70 drive

Once you have completed these steps, your BOOTP Server screen should have multiple entries in
the Relation List.

Note: Your EtherNet/IP hardware addresses will differ from the above screen
11. PanelView Plus 600 (manually configure from the PV terminal)
Navigation tips – Terminal setting –Networks and communications-Network connectionsNetwork adapters – IP address.
12. Select Disable the DHCP button. Select IP address and type in the IP address for your
PanelView Plus600. Now, select the Subnet Mask and type in ‘255.255.0.0’.
13. Select OK and select Close until you get to the RSView Station window.
14. Reset the device.
PC
1756-ENBT/B “Parent”
1756-ENBT/B “Child”
1794-AENT
Pview Plus 600
1756-EWEB
PowerFlex70 drive

IP addresses
192.168.1.1
192.168.1.2
192.168.1.3
192.168.1.4
192.168.1.5
192.168.1.6
192.168.1.7

15. Verify your EtherNet/IP interfaces are configured.
The OK LED on all nodes should be as follows:


1756-ENBT OK and NET LEDs – solid green



1794-AENT Network Status and Module Status LEDs – Solid green

15. PanelView Plus 600 – Refer to the navigation tips in step 11 above and verify that the
PanelView Plus 600 has the correct IP address.
16. Select File > Save.
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17. Save your BOOTP configuration in C:/RSLogix 5000/Projects folder, using your first and last
name.
18. Exit/Close the BOOTP server.
Now, it is time to verify that the modules are configured properly. We will use a utility called ” ping”.
19. When all the EIP interfaces have been configured, open a DOS prompt (Start > Programs >
Accessories > Command Prompt) and ping all the nodes, one at a time (for example, at the
DOS prompt, type: Ping 192.168.1.12)



FYI
Ping is an EtherNet/IP utility that verifies connectivity at the lowest level. You will
use it for troubleshooting.
After the class, if you want to read about ping, open a DOS prompt, type PING and
press Enter. To do this, your PC will need to have TCP/IP installed.

In the DOS prompt, you should see multiple Replies from the device you are pinging.
16. Also, ping your own PC’s IP address. This demonstrates that you can ping all EtherNet/IP
nodes. You will use this many times in the future.

17. Close the DOS prompt.
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Appendix B: Communication Formats
Read this document to learn about communication formats.
Communication format
When you configure an I/O module, you select a communication format for the module. The
communication format determines the data structure for the tags that are associated with the
module. Direct connection or rack-optimized connections are the most commonly used ones.
Rack Optimization
The Logix5000 controller uses connections to transmit and receive I/O data. For digital I/O
modules, rack-optimized communication is selected. A rack-optimized connection consolidates
connection usage between the controller and all the digital I/O modules in the chassis (or DIN
rail). Rather than having individual, direct connections for each I/O module, there is one
connection for the entire chassis (or DIN rail).
None
Is a real-time, direct connection used for data transfer between the controller and an I/O
module. The controller maintains and monitors the connection with the I/O module. Any break in
the connection, such as module fault, or the removal of a module while under power, sets fault
bits in the data area associated with the module. This type of communication format is also used
for peer- to- peer scheduled communication.
Input Data
In Logix5000 system, modules generate multicast data. This means that multiple modules can
receive the same data at the same time from a single module. While selecting a communication
format, you have to choose whether to establish an owner or listen only relation with the
module.
The controller that creates the primary configuration and communication connection to a module
is called an owner controller. The owner controller writes configuration data and can establish a
connection to the module. An owner connection is any connection that does not include ListenOnly in its Communication Format.
Listen-Only connection
This is an I/O connection where another controller owns/provides the configuration data for the
I/O module. A controller using a listen-only connection only monitors the module. It does not
write configuration data and can only maintain a connection to the I/O module when the owner
controller is actively controlling the I/O module.
Output Data
Only one controller is the owner of outputs to a device. An output data connection to a device is
the only connection that determines the mode (Program or Run) of that particular device.
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Appendix C: Adding Modules to I/O Configuration List
This Appendix if for informational purposes only and should not be treated as part of the lab
exercise.
Read this document to learn how to add modules to I/O configuration list in RSLogix5000.

Adding an Input Module to the Parent Rack
1. First, make sure you are Offline with your RSLogix5000.
2. Right click on I/O Configuration and choose New Module.
3. Find the 1756-IB16D in the module list as shown below and click on OK.

4. Select Major Rev 2 and Click OK.
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5. Configure the input module as shown below:

6.

Click on Next, the following screen appears.

7. Make RPI = 10 ms and click on Next to advance through the configuration screens to view COS
(Change Of State) and input filter settings.
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8. Verify that the selections match with the picture below:

9. Click on Finish.

Adding an Output Module to the Parent Rack
1. Right-click on I/O Configuration, choose New Module, and select the 1756-OB16D as shown
below.
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2. Click on OK.
3. When the following screen appears, select Major Revision 2 and click OK

4. Enter the configuration parameters as shown below: and click Finish.
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Adding EtherNet/IP Module to the I/O Configuration
1. To add a 1756-ENBT bridge to the I/O list, right click on I/O Configuration, select New Module,
and select 1756-ENBT as shown below:

2. Select OK.
3. When the following window appears, select Major Revision 3 and click OK.
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4. Configure the module as follows and then click Finish.

Configuring a Remote Ethernet Node
1.

Right click on the Parent 1756-ENBT and select New Module.

2. Select the 1756-ENBT from the list and then click OK.
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3. When the following window appears, choose Major Revision 3 and then click OK.

4. Configure the module as follows and then click the Next button.

To learn more about Communication Formats, refer to Appendix B.
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5. When the following window appears, change RPI from 10 to 20 and then click Finish.

When you configure an I/O module, you define the Requested Packet Interval (RPI)
for that module. The RPI specifies the period at which data updates occur. For
example, an input module sends data to a controller at the RPI you assign to the
module or the rack. You configure the RPI in milliseconds.
When finished, your I/O configuration tree in RSLogix5000 will appear as follows:
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Appendix D: Verifying the DeviceNet Scanlist
using RSNetworx for DeviceNet
This Appendix if for informational purposes only and should not be treated as part of the lab
exercise.
The steps below generate a scanlist for the DNB. A scanlist has already been loaded into your
DNB. You can verify or create a scanlist as follows:
1. From the computer desktop, double-click on RSNetworx for DeviceNet to launch the software.
2. From the toolbar menu, select Network > Online to browse the DeviceNet network.
3. From your PC, bridge to the 1756-DNB and out onto the DeviceNet network via the 1756-ENBT
in your remote 1756 (Child) chassis as shown below and then click OK.

4. If you see the following message, click on OK.
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5. When the 1756-DNB and photoeye appear in the graphics view as shown below, click Cancel
to stop the browse.

7. Double-click on the 1756-DNB and select the Scanlist tab.
9. Verify that there is a scanlist downloaded in the 1756-DNB.
10. Verify that the scanlist has a photoeye and that the Automap box is selected.
12. Verify the Photoeye configuration (default of COS is OK).
13. Close RSNetworx for DeviceNet.
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Appendix E: Drive Explorer
This Appendix if for informational purposes only and should not be treated as part of the lab
exercise.

Configuring / monitoring Drive Parameters Using DriveExplorer

1. From the computer desktop, double-click on the DriveExplorer icon.
2. From the toolbar menu, select Explore > Connect > Ethernet.

3. Click OK.
4. Highlight the IP Address as shown below and click on the Connect button.
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DriveExplorer connects on-line with the drive:

5. Click on the 20-COMM-E EtherNet/IP under PowerFlex 70 to display its parameters.

6. Click on the Device Properties icon

for displaying 20- COMM-E’s properties.
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7. Spend few moments to familiarize yourself with the information available under various tabs.
The User Text allows you a more descriptive name for the device.

8. Click on the Diagnostics tab to see actual data in the 20-COMM-E adapter.
The Diagnostics tab provides the ability from the drive side without knowing the controller or
the ladder program.

9. Click on the Close button.

Verifying Parameters in the 20-COMM-E
1. Verify the following parameters:


Pr. 23 [DPI I/O Cfg] – set to “x01” to allow Logic Command / Reference to transfer data
between the 20 COMM-E and the drive



Pr. 35 [M-S Input] – set to “x01” to allow Logic Command / Reference to transfer data between
the 20- COMM- E and the controller.
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Pr. 36 [M-S output] – set to “x01” to allow Logic Status/Feedback to transfer data between the
20- COMM- E and the controller.



Pr. 20 [Reset Module] - If any parameter is modified reset the adapter via Prameter20 for the
setting to take place.
Note that M-S Input and M-S output determines the 20-COMM-E’s I/O size on the
network. Because of the I/O size mismatch between 20-COMM-E, and ENBT, you
will see a warning icon in the RSLogix5000 I/O configuration menu and there would
not be any access to the drive through ladder program.

2. Click on the PowerFlex70 drive to display its parameters.
3. Scroll down to Parameter 90 for [Speed Ref A Sel]. Notice that “DPI Port 5” is selected.
4. Scroll down to Parameter 276 for [Logix Mask]. Notice that “DPI Port 5” is selected.
5. Scroll down to Parameter 300 to display the Datalinks. This tells drive which parameter to use
with the Datalinks. Parameters 140 and 142 contain Accel time and Decel time for the drive.

6. Close DriveExplorer.
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Accessing the Adapter’s Main Web Page
1. Type the IP address 192.168.1.7 in your internet explorer’s address location and press Enter.
2. When the following screen appears, navigate through different pages.
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