PDA

Ver la versión completa : Problema comunicación S7-200 TP 270 6''



adolfoe
18/06/2010, 03:17
Estoy haciendo un proyecto que involucra un panel táctil tp270 6'', y un PLC S7-200 de siemens. Para la programación estoy usando el WinCC Flexible 2007. Pero tengo problemas para lograr la comunicación, estoy algo confundido sobre como debo configurar la conexión o si lo estoy haciendo correctamente.

1)Estoy usando un cable hecho a mano, con dos conectores DB-9, los pines 1 y 9 van sueltos y los demás van uno a uno. Es decir 2-2,3-3,etc. De acuerdo a lo que investigué sobre el protocolo RS485.

2) Estoy usando el puerto IF1 B

3)Usé el DIP switch que trae el panel TP270 para cambiar la configuración del puerto IF1B, de MPI PPI a RS485.

4)Procedí a crear y configurar la conexión desde el WinCC de la cual se adjuntan las imágenes. Las principales características son:
*Modo ONLINE activado
*Panel de Operador
*Tipo: Simatic;
*Velocidad de transferencia: 19200
*Dirección: 1
*Unico maestro del bus: activado
*Red
*Perfil: Standard
*Maxima dirección de estacion: 31
*Número de maestros: 1

*Automata
*Dirección: 2
*Slot de expansión: 0
*Bastidor: 0
*Proceso cíclico: activado

Mis dudas son:
Estoy usando el perfil de red correcto?
La velocidad de transferencia es la correcta, o como la elijo?
A cual puerto del PLC debo conectar el cable, al 1 o al 0?
En la configuración de comunicación porque sólo me deja elegir la opción simatic y no las demás (RS422 TTY RS232 RS485)?
Debo configurar algo en el Step7 Microwin?

Muchas gracias.

Ferrani
18/06/2010, 12:07
Selecciona perfil MPI.

Mi proyecto con S7-200 y pantalla configuré la Red como perfil MPI.

Cuentanos si es eso.

Saludos

adolfoe
23/06/2010, 02:06
Hola, gracias por su respuesta.La configuración que me resultó al final es la PPI a 9600 bauds. Más alto que eso me generaba problemas, creo que eso se puede cambiar con la configuración del panel pero no estoy seguro.

Gracias por sus sugerencias.