PDA

Ver la versión completa : Ayuda con flanco en S7-200



pedrito
02/06/2010, 06:37
Hola gente.

Necesito detectar un flanco descendente en un S7-200 y estoy harto de hacer pruebas y no lo consigo.

Tengo una fotocelula que da señal al plc cuando no hay pieza y deja de darla cuando detecta pieza.

Necesito activar una marca con un Set solo cuando se detecte la pieza y no pueda volver a activarse hasta perder la señal y detectar la siguiente.
He probado con LPS EU y LPP ED y no me aclaro. El caso es que no lo consigo. He seguido los ejemplos de la ayuda y tampoco.
Si podéis ponerme un ejemplo AWL os lo agradezco.

Gracias.

lluisot
02/06/2010, 07:53
El flanco del 200 afecta a todo lo que esta a la izquierda del mismo .Mira en el foro . Hay algo al respecto .

i0.0 ....../n/...m0.1.....i0.2.......sm0.0

Al ser negativo , cualquier condicion que pase a 0 aunque no sea la fotocelula antes del flanco puede provocarte el set de la marca .

villasdebur
02/06/2010, 13:36
Pones el bit de entrada de la fotocelula y el flanco si lo quieres positivo o negativo.

Te dejo una captura

pedrito
02/06/2010, 15:06
He hecho una prueba en el simulador y parece que ahora si funciona. Me falta probar físicamente con el programa completo.
No sabía que el flanco afecta a lo que hay en su izquierda. Pensaba como Omron que lo hacía sobre las salidas directamente y claro que había señales que estaban interfiriendo por delante del flanco, así que no iba ni pa Dios.

Creo que ahora voy por mejor camino.

Gracias a todos.