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We reserve the right to change the contents of this manual without warning. The
information contained herein is believed to be accurate as of the date of publication,
however, Bernecker + Rainer Industrie−Elektronik Ges.m.b.H. makes no warranty,
expressed or implied, with regards to the products or the documentation contained
within this book. Bernecker + Rainer Industrie−Elektronik Ges.m.b.H. shall not be
liable in the event of incidental or consequential damages in connection with or
arising from the furnishing, performance or use of these products.
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Introduction
Features
B&R Automation Studio™ provides you with a development system for all
automation tasks. B&R Automation Studio™ features:

Features
Description
Microsoft
The B&R Automation Studio™ desktop complies with the Microsoft
Windows
design guidelines for Windows programs. This makes it easier to
Look & Feel become familiar with the program and reduces project engineering
costs.
Supports
The B&R Automation Studio™ development environment supports
Many
many different target systems. This allows the automation platform to
Target
be scaled to meet your exact requirements.
Systems
More than In addition to IEC 1131 languages, B&R Automation Studio™ offers
IEC 1131
high level language programming using ANSI C and complete line of
high performance technology functions which greatly simplify project
engineering for your machines and systems.
Startup
All diagnosis and service tools clearly show system behavior using
graphic displays. Synchronous recording of data replaces an
oscilloscope and allows exact settings to be made for machine
parameters.
Contains all B&R has completely integrated all product information that is relevant
Information during the creation and development of your B&R Automation
Studio™ projects. Standard help functions provide easy access of all
details related to the operation of this tool. Hardware specific data is
placed in user−friendly registers.
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The most important tools
The following table provides a rough overview of the most important tools in B&R
Automation Studio™ and their functionality.

Tools
Hardware
Configuration

Software
Configuration

Programming
Languages

Libraries and
Function Blocks

Visualization

Functionality
Hardware Configuration features:
• Automatic recognition of the target system
• Graphic display of the target system
• Detailed information about the target system
• Simple definition of target system profiles
• Direct assignment of symbolic variables to physical
terminals
Software Configuration features:
• Efficient configuration of the target system
• Clear display of project hierarchy
• Simple definition of software profiles
B&R
Automation
Basic™
C Program
Ladder
Diagram
Sequential
Function
Chart
Instruction
List
Structured
Text

... previously PL2000

... ANSI C
... IEC 1131 Ladder Diagram (abbr.: LAD)
... IEC 1131 Sequential Function Chart (abbr.:
SFC)
... IEC 1131 Instruction List (abbr.: IL)
... IEC 1131 Structured Text (abbr.: ST)

Many standard functions (function blocks) are included in the
delivery of B&R Automation Studio™ which are grouped
together in various libraries. Each library contains function
blocks which can save you a lot of time and effort when
creating solutions to standard problems.
Using the Visual Components in B&R Automation Studio™,
process images and other visualization elements can be
created and tested together with the control task. The
following tools are integrated:
• Picture Editor
• Alarm System
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Technology
Functions

Modular technology plug−ins allow homogenous integration of
high performance tools.
• Set, analyze and diagnose axis/drive parameters
• CNC Editor
• Cam Editor

Diagnosis, Service,
etc.

Chapter 1 − Introduction

• Online variable force
• Online variable monitor
• Real−time trace
• Complete source level debugger with break point,
single step, line coverage and disassemble functions
• Logbook makes it easy to determine system status
• Profiling function − Task and system runtime
measurement
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What can I find in this manual?
This manual provides you with an introduction to B&R Automation Studio™ allowing
you to get started quickly. It will also provide an overview and helpful tips.
Don’t be shocked by the size of this manual! You should only need approx. 1 to 2
hours to work through the most important chapters (Chapter 2 "Installation" and
Chapter 3 "The First Steps").

Chapter
Chapter 1

Contents
Chapter 1 "Introduction" provides you with general information
required to this manual.
Chapter 2 Chapter 2 "Installation" provides you with all of the important
information required to install B&R Automation Studio™.
Chapter 3 Chapter 3 "The First Steps" uses examples to introduce you to the
functions available in B&R Automation Studio™. If you work through
this chapter, you will become familiar with B&R Automation Studio™
and also collect a lot of useful information.
Appendix A Appendix A "FAQs" provides answers concerning the following topics:
• Installation and update of the B&R Automation Runtime™
operating system
• Adding or exchanging modules in a project
Appendix B Appendix B "Key Combinations for Command Calls" contains an
overview of all key
combination used in B&R Automation Studio™ to directly call
commands.
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Conventions
In order to be able to find and interpret information quickly and easily in this manual,
visual orientation guidelines such as standard text formats and symbols are used.
The following conventions are used.
Visual Orientation Guidelines
In this manual, you will continually find the following typographic conventions:

Convention
CAPITALS
Bold in
Upper/Lower
Case Letters
Bold Italics
"In Quotation
Marks"
SMALL
CAPITALS

Description
Directory names, file names, etc. are shown in capitals.
Menu items, command names, names of dialog fields, buttons and
options are shown in bold.
Important terms and information are shown in bold italics.
All text that has to be entered in fields and references to other
sections are shown in quotation marks.
Names of keys on your keyboard, e.g. CTRL KEY, ESC KEY, etc.
Important remarks and tips are shown using this symbol.
Explanations of new terms are shown using this symbol.

Format of Key Combinations, Sequences
Key combinations and sequences are differentiated as follows:

Key
Combinations
KEY1+KEY2
KEY1, KEY2

Description
A plus (+) between key names means that the first key is held
down while the second is pressed.
A comma (,) between key names means that both keys are
pressed and released in sequence.

Chapter 1 − Introduction
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Where do I find answers to my questions?
Online help
The B&R Automation Studio™ online help can be called at any time, providing you
with information concerning the operation and function of B&R Automation Studio™.
To start the online help, click on "Help" in the "?" menu.
If you need help for the active window or dialog box, simply press the F1 key.

This manual
In addition to basic information about B&R Automation Studio™, this manual also
contains descriptions of often used procedures.
Appendix A "FAQs" contains answers to frequently asked questions and Appendix
B "Key Combinations for Calling Commands" contains an overview of all key
combinations used in B&R Automation Studio™ to directly call commands.

Service and support
B&R will be there for you when you need information or advice. If you have
questions that are not answered in our documentation, get in touch with your service
partner at B&R.
Internet / email
B&R can also be reached via Internet under http://www.br−automation.com. This
address provides you with information concerning our products and which email
addresses you can use to reach us. New program versions and updates are also
available on our WWW pages.
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Installation
System requirements
The Computer where you are going to install B&R Automation SoftwareTM has to
meet the following requirements.

Operating system
Processor
Working Memory
Hard disk
Graphics

Recommended
Windows 98, Windows ME, Windows NT 4.0, Windows
2000, Windows XP
at least Pentium 166 MHz
at least 64 MB
at least 300 MB available
SVGA (800 x 600)

Your computer has to have available online interface for the communication
between your programming device (computer) and the target system (controller).
For example COM 1 − 4 or CAN interface can be used as online interface.
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Installation of B&R Automation Studio
With Windows NT Operating System you need Administrator rights
to install any software! If necessary get in touch with your network
administrator.
1. Close all other Windows programs.
2. Insert the installation CD on the CD−ROM drive .
3. If Autostart is enabled on your system the installation window "B&R
Automation Installation" will be displayed. If autostart is disabled run
'BrMenu.exe' from the root directory of your installation CD.

Select the B&R Automation Studio  entry with the cursor buttons up and down, and
start the installation with the Start button.

Installation sequence of B&R Automation Studio 
The installation sequence of B&R Automation Net and B&R Automation Studio is
splitted in
1. B&R Automation Net (PVI) installation
2. B&R Automation Studio installation
B&R Automation Net (PVI) is included in the B&R Automation Studio installation.
Automation Net is the communication base and therefore the first installed
component on the system.
Afterwards the B&R Automation Studio will be installed in an own, versions specific
tree.
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Installation of MS Internet Explorer
If your MS Internet Explorer Version 5.0 (or higher) is already
installed on your computer, you can pass by the following steps and
go to "Installation of B&R Automation Software".
With Windows NT Operating System you need Administrator rights
to install any software! If necessary get in touch with your network
administrator.
1. Close all other Windows programs.
2. Insert the installation CD on the CD−ROM drive.
3. If Autostart is enabled on your system the installation window "B&R
Automation Installation" will be displayed. If autostart is disabled run
'BrMenu.exe' from the root directory of your installation CD.

Select the Internet Explorer with the cursor buttons Up/Down and start the
installation with the Start button. The installation of the Internet Explorer is menu
controlled. If the installation was successfully completed you are asked to restart
your system.

Chapter 2 − Installation
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User Information

Insert User and Company name and continue with Next − Button

Program Folder Definition

If the entries are confirmed, a new program folder will be made. If you agree with the
default folder name press NEXT button, otherwise enter a new name.
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Selection of components

Select to components you would like to install and press the NEXT button to
confirm.
Now the decompress and copy process starts.

The installation progress is indicated.
If the installatoin is ready you are asked to license your B&R Automation Studio.

Chapter 2 − Installation
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Licensing
If the B&R Automation Studio is not jet licensed, following dialog is displayed:

Enter the supplied serial number (from the back side of the CD Cover)
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A system code will be calculated, with this code enter into B&R Homepage Service
(e−service) to get the License code.

Enter this code in field (License code [Sec−ID]).

If the code is correct you can exit the licensing with the OK button
If no valid B&R serial number is entered, you can exit with the "License later" button
to start an evaluation period of 30 days.
The evaluation time will be displayed at the start of Automation Studio. During this
time B&R Automation Studio has no restriction.
If the evaluation time is expired, the software must be licensed, otherwise you can
not start the B&R Automation Studio anymore.
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Uninstall B&R Automation Studio
If you are using multiple installation of B&R Automation Studio, only an
active version can be uninstalled from PC.
If not active please use the Version Changer to change the status (see
version changer help)
If you want to remove B&R Automation Studio from your PC start the UninstallShield
as shown in the following window.

If the uninstall wizard was started, you are be able to select the program be
uninstalled.
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If the Uninstall sequence is finished but the following message is displayed (see
dialog underneath), the uninstall manager was not able to remove all files in the
B&R Automation directory. In this case delete this files and the directory manually, if
not used anymore.

Valid for multiple installations:
If another version of B&R Automation Studio is available after a different
version has been uninstalled, then the remaining copy needs to be
activated using the Version Changer.
Uninstall B&R Automation Net (PVI)
If you want to uninstall B&R Automation Net (PVI), all B&R Automation
Studio versions have to be uninstalled previously.

If you want to remove B&R Automation Net from your PC start the UninstallShield as
shown in the following window:

If the uninstall wizard was started, you are be able to select the program be
uninstalled.

Chapter 2 − Installation
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If you confirm with the OK button, the uninstall sequence starts for the software
selected.
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The first program start
The installation is divided into 2 sections:
B&R Automation Net(PVI) Installation
B&R Automation Studios™ Installation

In the following sections of this chapter, we will assume that the following settings
were entered during the installation of B&R Automation Studio™:
B&R Automation Net(PVI) Installation
Path to target directory for the installation:
C:\BrAUTOMATION
Name of the B&R Automation Studio™ program group:
B&R AUTOMATION
B&R Automation Studio™ Installation
Path to target directory for the installation:
C:\BR_AS_XXX_L0XX (e.g. C:\BR_AS_220_L001)
Name of the B&R Automation Studio™ program group:
AUTOMATION STUDIO X.XX English
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Start B&R Automation Studios
B&R Automation Studios™ is started as follows:
• Click on the Start button and go to the program menu.
• Go to the folder B&R Automation and start the program B&R Automation
Studio:

After starting B&R Automation Studio™, the start screen is shown for a short time
and then B&R Automation Studio™ is opened.

Starting an Evaluation Version
If B&R Automation Studio™ has not been licensed, it can only be run for 30 days.
The remaining evaluation period is shown each time B&R Automation Studio™ is
started. Operation is possible during this period without limitations.

The licensing dialog box is opened by clicking on the OK button. You can either
license the software or open the evaluation version by clicking on the License later.
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After the 30 days have passed, B&R Automation Studio™ can no longer be started.
"Evaluation ended" is shown. The licensing dialog box is opened by clicking on the
OK button. For more information see "Chapter 1 −> Installation −> Licensing".

Start screen

Chapter 3 − First Steps
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B&R Automation Studio
B&R Automation Studio™ Window:

No.
Name
Description
1 Main menu The B&R Automation Studio™ main menu changes according to
the active editor. In this way, you can select from the functions
needed for the active editor.
2
Toolbar Contains toolbar icons that provide fast access to various
commands and functions. If you place the mouse pointer over the
icons, the name is shown. Use the Toolbars... command in the
View menu to show or hide toolbars
3
Program The window for an open project is shown in this area. This
Workspace window can be maximized in this area for sized as required.
4
Message The message window is shown in the lower part of the program
Window window after the first time B&R Automation Studio™ is started.
The message window shows e.g. compiler and debugger
messages.
5 Status line The status bar at the bottom of the window shows information
such as:
• Short help information for menu commands or tool bar
icons.
22
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• Short information concerning editing procedures.
• Current position in a list, tree or text
• Status of the online connection between the programming
device and the target system (see "Chapter 3 −> How to
create a project? −> Creating a New Project").
• Status of the target system (RUN, STOP, DIAG)
• Status of various keys (CapsLock, Num, Scroll)

Exiting B&R Automation Studio
Exit B&R Automation Studio™, by ...
... clicking on Exit in the File menu, or
... clicking on the button in the top right corner of the B&R Automation Studio™
window.

Keyboard and mouse operation
The B&R Automation Studio™ desktop complies with the Microsoft design
guidelines for Windows programs. That means keyboard and mouse operation also
correspond to the Windows standard. If you have already worked with Windows, you
will be able to find your feet quickly in B&R Automation Studio™.
Additional information concerning the operation of B&R Automation Studio™ can be
found in the online help. To start the online help, click on "Help" button in the "?"
menu or press F1.
Appendix B −> "Key Combinations for Command Calls" contains an overview of all
key combination used in B&R Automation Studio™ to directly call commands.
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Example Program
In the following sections, we will get the ball rolling by writing a short example
program in B&R Automation Studio™ using the ladder diagram (LAD) programming
language.

Task description
We will create a project called "AS_QS" in directory "D:\PROJECTS". Then we will
open the project and enter the circuit plan shown in the following illustration using
LAD.

This example program be saved in the project "AS_QS" under the name "logic1".

Hardware requirements
In this manual, the following hardware is used as the target system for all example
programs:
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PS465
IF260
IF060
DI475
DO479
AI375
AO350
BM150

Power supply module
CPU
Interface module
Digital input module
Digital output module
Analog input module
Analog output module
Dummy module
(to fill unused slots)

Many pictures and information in the following sections refer to this hardware
configuration. However, you can also use different hardware. To run this example
program, you will need at least the following hardware components:
• Power supply module
• CPU
• Digital input module
• Digital output module
Without the hardware components listed above, you can program the example but
you can’t test it.

Chapter 3 − First Steps
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How to create a project?
A project contains all information for a system/machine, including all programs and
the corresponding data banks. In order to be able to enter an example program, you
have to create a project.

Preparation
B&R Automation Studio™ is a hardware oriented programming system. That
means the hardware has to be defined when creating a project. B&R Automation
Studio™ can carry out automatic hardware recognition when creating a project. For
inexperienced users, this is the simplest type of hardware definition.
The online connection has to be configured properly so that B&R Automation
Studio™ can determine the hardware configuration on the target system. Before
creating a project, check the connection between the programming device
(computer) and target system (controller).
To establish an online connection, the B&R Automation Runtime™ Operating
System must be installed on your target system.

B&R Automation Runtime™ is an adjustable, deterministic real−time
multitasking operating system.

With the exception of the B&R SYSTEM 2010 CPUs (CP10x and CP2x0), B&R
delivers all processor modules with the B&R Automation Runtime™ operating
system preinstalled.
When using a new B&R SYSTEM 2010 application memory, the operating system is
not yet installed. If the operating system is not installed, and operating system
download has to be carried out. An exact description of this procedure can be found
in Appendix A "FAQs", Section "1 How do I install the operating system?".

How to make a connection between the programming device and
PCC?
The connection between the programming device and controller is made using an
online cable (Model No.: 0G0001.00−090).
Take note of the following points when making an online connection using this
cable:
• COM1, COM2, COM3 or COM4 has to be free on your computer.
• The online cable has two 9 pin D−type sockets. The serial interfaces on
some computer use a 25 pin D−type plugs, therefore you might need an
26
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adapter. These type of adapters are often included with a mouse. Otherwise
you can get an adapter from a local supplier.
• The online cable is only for a connection between two RS232 interfaces. Do
not use an adapter to connect the serial interface COMx with an
RS485/RS422 interface. You need a special interface converter to do this!
The communication can also take place using an ETHERNET interface. The CAN
interface on B&R Industrial PCs can also be used as online interface.
When using a LS251 Logic Scanner CPU, the online connection is made via the PCI
Bus and SRAM on the LS251.

Establishing the online connection
In our example, communication with the controller should take place via the COM2
serial interface on the programming device.
Before the programming device and the controller are connected with each other,
make sure that the controller is turned on (is power applied?). Then take the online
cable and connect the RS232 interface on the CPU with the serial interface COM2
on the programming device:

After this is done, the online connection has to be configured. To do this, select
Options... from the Tools menu in B&R Automation Studio™. The online interface
can be configured in the dialog box shown.

Chapter 3 − First Steps
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After installing B&R Automation Studio™, the serial interface COM2 is selected as
default. To change the configuration of the interface, click on the Properties button.
The settings can be changed in the Serial Properties dialog box. For our example,
we will not change the standard settings.
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Descriptions for other settings in the Options dialog box can be found in the online
help. The defined parameters are accepted when this dialog box is closed by
pressing the OK button.
If the online interface is configured correctly, the online connection between the
programming device and the controller will be established automatically when the
project is opened (see "Chapter 3 −> How to create a project? −> Creating a New
Project").

Creating a New Project
B&R Automation Studio™ is a hardware oriented programming system. That
means the hardware has to be defined when creating a project. We differentiate
between Automatic Hardware Recognition and Manual Hardware Definition.
Automatic Hardware Recognition
B&R Automation Studio™ can carry out automatic hardware recognition when
creating a project. For inexperienced users, this is the simplest type of hardware
definition.

Chapter 3 − First Steps
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To create a new project, select the New Project... command from the File menu.
Then the New Project Wizard is opened. In this dialog box, you can enter the
desired project name (Name) and the path to the project directory (Path). For our
example project, we will use the project name "AS_QS" and the project should be
saved in the "D:\PROJECTS" directory:

If you want to use a project name other than "AS_QS", read the
limitations for project names given in context sensitive help!
In order to be able to upload the hardware configuration from the
controller automatically (automatic hardware recognition), select Upload
hardware from target!

If the directory "D:\PROJECTS" doesn’t exist, you will be asked if it should be
created when you press the Next > button. Answer this question with OK.
B&R Automation Studio™ then carries out automatic hardware recognition. The
progress is shown in a dialog box. When the hardware recognition is complete, you
can open the next dialog box by clicking on Next >:

30
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This dialog box shows all previously defined data along with the CPU found during
hardware recognition. Power supplies do not have a hardware code, therefore they
cannot be automatically recognized by B&R Automation Studio™. They can be
added to the hardware configuration manually later (see "Appendix A −> How can
I work without hardware?").
Check the data again. You can go back and correct data by clicking on < Back. If
the data is correct, click on Finish to create and open the project.

Manual Hardware Definition
Manual hardware definition is mostly used when the target system is not available.
The following section describes the procedure for project creation using manual
hardware definition.
To create a new project, select the New Project... command from the File menu.
Then the New Project Wizard is opened. In this dialog box, you can enter the
desired project name (Name) and the path to the project directory (Path). For our
example project, we will use the project name "AS_QS" and the project should be
saved in the "D:\PROJECTS" directory:

Chapter 3 − First Steps
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If you want to use a project name other than "AS_QS", read the
limitations for project names given in context sensitive help!
For manual hardware definition, Upload hardware from target has to be
deactivated!

If the directory "D:\PROJECTS" doesn’t exist, you will be asked if it should be
created when you press the Next > button. Answer this question with OK.
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Then you have to define the CPU on the target system. A list of all possible modules
is shown:

Select the desired CPU from the list and then click on Next >. Another dialog box is
then opened where you can select from a list of all power supply modules that can
be used with for the selected CPU. Select the desired power supply and then click
on Next >. The next dialog box shows all previously defined data and the modules
defined manually (model number of the CPU and power supply modules):

Chapter 3 − First Steps
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Check the data again. You can go back and correct data by clicking on < Back. If
the data is correct, click on Finish to create and open the project.

During manual hardware definition, only the CPU and power supply
modules are defined. All other modules (e.g. digital or analog I/O
modules) have to be set after manual hardware definition. A detailed
description of this procedure can be found in Appendix A −> How can I
work without hardware?.

Connection status
If the online interface is configured correctly, the Online Connection between the
programming device and the target system is established automatically when a
project is opened. The connection status is shown in the status bar:

Active Connection
Active connection between programming device and target system:

The text in the status bar contains the following information:
Status
Bar
COM2
IF260
V2.29
RUN

Information
Shows the interfaced used on the computer as online
interface.
Shows the processor type (name of the CPU) and the
operating system version used.
Mode that the processor is in:
RUN =
SERV
=
DIAG
=

34

RUN Mode
SERVICE
Mode
DIAGNOSE
Mode
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No Connection
No connection between programming device and target system:

If a connection cannot be established even though the interface
configuration is correct, check again to see if the B&R Automation
Runtime™ operating system is installed on the controller! Have a look at
"Chapter 3 −> How to create a project? −> Preparation").

Work environment
You probably noticed that the B&R Automation Studio™ main menu changes when
you open a project. A "Project Window" is also opened.
The project window is the heart of each project. It is shown as a two part window:

The left section of the window gives an overview of the hardware used in the project
(hardware configuration). The right section of the window provides additional
information and settings for the marked module.

Chapter 3 − First Steps
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Left Window Section
The left section of the window gives an overview of the hardware used in the
project.

The left section of the project window is called the hardware configuration.

The easiest way to define the hardware in a project is using automatic hardware
recognition (see "Chapter 3 −> How to create a project? −> Creating a New
Project"):
• When creating a new project, the user can let B&R Automation Studio™
upload the available hardware from the controller.
• If there is an active connection between the programming device and the
target system, the current hardware on the target system is compared with
the hardware configuration (shown in the project window).
If there are hardware differences, the modules in the current project that are
different from the modules on the controller are marked:

Symbol

Description
A different module is in this slot on the controller! You
can replace the module by marking it and calling the
context menu (right mouse button).
No module is in this slot on the controller!

Right Window Section
The right section of the window contains additional information and settings for the
module marked in the left section. The right section is divided into registers in order
to show the information more clearly.
Which registers are shown depends on which module you have marked in the left
section.

Register
Description
Software This register card allows access to the software
configuration (see below).
Logbook
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This register card shows entries from the logbook on the
PCC.
The software configuration is integrated in the right section of the project
window. Each module that can run software (CPU or parallel processor) has
a register card software. This register card is also called the software
configuration.
You can configure the B&R Automation Runtime™ operating system
performance to suit your application using the software configuration (you can
find an in−depth description of the software configuration in the online help).
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Register
I/O

38

Description
Module configuration: Displays all data points on the
module. This list varies according to the properties of a
module.
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Variable declaration
We need the following process variables for our short example program (abbr.
PVs):
key_1 ......... digital input
relay_1 ....... digital output
There are several ways to declare these two process variables. The variable
declaration method shown on the following pages is the easiest for beginners.

Digital input
The digital input "key_1" can be defines as follows:
• In the left section of the project window, click on the symbol for the DI475
module (digital input module). The registers I/O is then shown in the right
section of the window.
• If you click on the I/O register card, a list of all data points on the DI475
module is shown.
• To assign the variable name "key_1" to the first digital input on the DI475
module ...
... double click on the PV Name column in the first line of the list
and enter the variable name "key_1". The entry for the variable
name is completed when the ENTER key is pressed.
... place the cursor on the PV Name column in the first line of the
list and press the SPACEBAR. Then you can enter the variable
name "key_1". Press ENTER to complete the entry.
• Variable names can be up to 32 characters long.
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• The Remark column normally contains a short function description for I/O
on the module marked. You can enter an optional description with up to 34
characters in this column. To do this, double click on the Remark column
and enter the desired text. Press ENTER to complete the entry.
The additional description is only for documentation and is not transferred to
the controller.

Digital output
The digital output "relay_1" can be defines as follows:
• In the left section of the project window, click on the symbol for the DO479
module (digital output module). The registers I/O is then shown in the right
section of the window.
• If you click on the I/O register card, a list of all data points on the DO479
module is shown.
• To assign the variable name "relay_1" to the first digital output on the
DO479 module ...
... double click on the PV Name column in the first line of the list
and enter the variable name "relay_1". The entry for the variable
name is completed when the ENTER key is pressed.
... place the cursor on the PV Name column in the first line of the
list and press the SPACEBAR. Then you can enter the variable
name "relay_1". Press ENTER to complete the entry.
• Variable names can be up to 32 characters long.
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• The Remark column normally contains a short function description for I/O
on the module marked. You can enter an optional description with up to 34
characters in this column. To do this, double click on the Remark column
and enter the desired text. Press ENTER to complete the entry.
The additional description is only for documentation and is not transferred to
the controller.
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Creating a cyclic object
Now we will enter our example program using the ladder diagram (LAD)
programming language. We will create a cyclic object for the example program
because it is to be processed cyclically.

Inserting a cyclic object
A cyclic object is inserted in the following manner:

• In the left section of the project window, select a module that can contain a
software object (CPU or PP). In our example, this is the IF260 module.
• Select the Software register in the right section of the window.
• Insert a new object by...
... clicking on New Object… in the Insert menu, or
... click on the CPU symbol with the right mouse button and select
the Insert Object... command from the context menu shown, or
... click on the CPU symbol and then press the INS key.
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• In the Insert Object dialog box shown, select resource type Cyclic Object
and acknowledge the selection by pressing the Next > button.

Resource Types
The following resource types can be selected from the dialog box Insert Object:

Resource
Description
Cyclic
A cyclic object is executed in a defined time frame
Object
(cycle time). The operating system monitors to make
sure the cycle time is not exceeded.
To assign priorities, cyclic objects can be assigned
various resources (different cycle times).
Cyclic objects that carry out important, time critical
tasks are assigned a resource with a shorter cycle
time and are therefore executed more often than
objects assigned a resource with a longer cycle time.
Cyclic objects include:
• Cyclic objects
• Timer objects
• Interrupt objects
• Exception objects
Non−Cyclic This resource is deactivated as default because it is
Object
reserved for internal B&R functions (e.g. drivers).
Data
Data objects are modules used to store data.
Object
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System
Object

Advanced
Object

B&R modules (*.BR files) can be transferred to the
controller as system objects. System
objects include libraries or objects with additional
system functions. Many of these objects
are loaded by B&R Automation Studio™
automatically and don't have to be inserted
manually.
Library: A collection of standard functions is
represented in B&R Automation Studio™ by a B&R
module (library). Each library contains functions that
can save you time and effort solving standard
problems. If a function from a library is used, that
library is automatically imported into the project and
installed on the controller during the next transfer.
NC axes, CAM profiles, etc..

Define object name, object type and recourse
After defining the resource type in the Insert Object dialog box, the New Object
dialog box used to define the object name, object type and resource is opened:

Enter the desired name in the Name field ("logic1" in our example) for the new
object. Take note of the limitations for object names described in the context
sensitive help! Then select Ladder Diagram for the object type (Type field) and
Cyclic #1 − [10 ms] for the resource (Resource field).
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You can assign various resources to object to define priority between the
individual cyclic objects. A cycle time can be set for each cyclic resource and
each timer resource.
All objects assigned this resource are executed once within this cycle time.
Objects that carry out important, time critical tasks are assigned a resource
with a shorter cycle time and are therefore executed more often than objects
assigned a resource with a longer cycle time.
After acknowledging these entries by clicking on the Finish button, the cyclic object
is entered in the software configuration and the LAD editor is opened.
Object Types
The following object types are presently possible for cyclic objects (see Type in the
New Object dialog box):
B&R
Automation
Basic™
C Program
Ladder
Diagram
Sequential
Function
Chart
Instruction
List
Structured
Text

... previously PL2000
... ANSI C
... IEC 1131 Ladder Diagram (abbr.: LAD)
1131 Sequential Function Chart (abbr.:
... IEC
SFC)
... IEC 1131 Instruction List (abbr.: IL)
... IEC 1131 Structured Text (abbr.: ST)
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Resources
The following resources are possible for cyclic objects (see Resource in the New
Object dialog box):
Timed Resources
Resource

Description
Objects assigned this resource are executed cyclically.
The B&R Automation Runtime™ operating system
calls these objects. Cyclic resources have a fixed name
(Cyclic) which the cycle time is added to (time for one
cycle).

Cyclic #x
− [....ms] Example:

Objects with this resource are carried out cyclically
using special hardware timers. Timer resources offer a
high degree of consistency and have higher priority
than cyclic resources. Timer resources have a fixed
name (Timer) which the cycle time is added to (time for
Timer #x one cycle).
− [....ms]
Example:

All resources described up to this point (cyclic resources and timer
resources) are time controlled. However, there are also resources that are
not time controlled, instead are carried out when a certain event occurs.
We will differentiate between two types of event controlled resources:
interrupt resource and exception resource.
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Event Driven Resources
Resource
Description
Interrupt Interrupts are asynchronous event (triggered by
hardware) that interrupt cyclic program execution.
Interrupts can only be generated by special hardware.
An example of an interrupt capable module is the
DI400 digital input module (B&R SYSTEM 2010). 8
digital inputs can be used as CSI inputs (CSI =
"Change of State Interrupt") on this module. If the state
of an enabled CSI input changes, an interrupt is
triggered on the CPU.
An object can be created for each interrupt capable
module to handle the event.
Exception Exceptions are signals that come from the B&R
Automation Runtime™ operating system and indicate
certain exception states. They can be compared to
interrupts triggered by the system to indicate a fatal
error. Objects which are assigned an exception
resource, can be used to react to these fatal errors
(e.g. inserting and removing I/O modules, power failure
for RIO slave, etc.).

Entering the ladder diagram
Now we will program the circuit diagram (see "Chapter 3 −> Example Program −>
Task Description") in the ladder diagram editor (abbr.: LAD Editor).
Inserting the Digital Inputs
Digital inputs can be inserted in the LAD editor as follows:
• Add a digital input symbol by ...
... clicking on

in the toolbar, or

... pressing the C key, or
... clicking on the Contact command in the Insert menu and
selecting Normally Open Contact from the submenu shown.
• Then assign the digital input "key_1" to the contact by ...
... entering the variable name "key_1" and pressing the ENTER
key. or
... pressing the SPACEBAR. Then a list of all defined process
variables will be shown. Select "key_1" from this list and click on the
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Add button.
The list only contains variables that are compatible with the data
type of the new contact!
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Drawing Connection Lines
Connection lines can be drawn using the key combination ALT+CURSOR KEYS or
with the
,
,
and
buttons.

Inserting the Digital Outputs
Digital outputs can be inserted in the LAD editor as follows:
• Add a digital output symbol by ...
... clicking on

in the toolbar, or

... pressing the key combination SHIFT+C, or
... clicking on the Coil command in the Insert menu and selecting Coil from the
submenu shown.
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• Then assign the digital output "relay_1" to the contact by ...
... entering the variable name "relay_1" and pressing the ENTER key. or
... pressing the SPACEBAR. Then a list of all defined process variables will be
shown. Select "relay_1" from this list and click on the Add button.
The list only contains variables that are compatible with the data type of the new
contact!

Checking and Optimizing LAD
If you click on the
button in the toolbar or press the ENTER key, the ladder
diagram is checked for open connection lines or other errors and optimized (extra
connection lines are deleted, etc.). Check and optimize ladder diagram:
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View Information On/Off
In the ladder diagram, it is possible to show additional information. The commands
Type, Scope and Remark from the View menu and the context menu of the LAD
editor (called with the right mouse button in the LAD editor) can be used to select
which information is to be shown. A check to the left of the menu command means
that this information will be shown.

Meaning of the additional information:
Information
Type
Scope
Remark

Description
Data type of process variables (detailed information
concerning "data type" can be found in the online
help).
Valid range of process variables (detailed information
about the scope can be found in the online help).
Up to 34 character long description of the process
variable (see "Chapter 3 −> Variable Declaration").

Saving and Closing LAD
To save the ladder diagram "logic1" on the programming device hard drive
(D:\PROJECTS\AS_QS\...)
... click on the

button in the toolbar, or

... press the key combination CTRL+S, or
... select the Save command from the File menu.
When saving, the ladder diagram is checked and optimized again. After saving, you
can close the LAD editor.
Close the LAD editor by ...
... clicking on Exit in the File menu, or
... clicking on the

button in the upper right corner of the LAD editor window.
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Compiling / transferring objects to the controller
The ladder diagram has to be converted to machine language for the processor on
the controller. B&R Automation Studio™ has a compiler for this purpose. The
compiler provides an executable program module (B&R module) in machine
language for the processor.
Before compiling the example program "logic1" and transferring it to the controller,
you have to define the memory area that will be used as target for object transfer.

Defining the memory area
To define the target memory area for the object "logic1", click on the object symbol
in the software configuration and select the Transfer to command from the Object
menu. A list of all memory areas possible for this object is shown:

Select the memory area User RAM from this list for the example program. Then the
object will be stored in User RAM on the controller during transfer.
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Overview of possible memory areas:
Memory
Description
Area
User−RAM User RAM is a conditionally nonvolatile memory area (buffered when
power is not applied to the controller) and is available for application
software (cyclic objects, data objects, etc.).
User−ROM User ROM can be used to store cyclic objects, data objects, etc. in
nonvolatile memory. User ROM is in the form of a Flash PROM.
FIX−RAM Using B&R Automation Studio™ (software configuration), you can
configure a part of User RAM to behave like User ROM during a
COLD RESTART. This memory area is called FIX RAM.
Objects stored in FIX RAM are not deleted during a COLD RESTART.
COLD RESTART boot mode corresponds to the first time a processor
is initialized. The operating system is restarted and all RAM data
(except objects stored in FIX RAM) is deleted.
MEM−Card Some processor modules can be equipped with a PCMCIA memory
card (also called MEM card). The MEM card can be used to store
cyclic objects, data objects, etc. in nonvolatile memory. That means
this memory corresponds to either the User ROM (MEM Card as
Flash PROM) or FIX RAM (MEM Card as SRAM).
SYS−ROM The operating system B&R Automation Runtime™ is stored in
System ROM. System ROM is a nonvolatile memory area in the form
of a Flash PROM.
DRAM
The object is stored directly in DRAM when transferred to the
controller. DRAM is a nonvolatile memory area and is available for
application software (cyclic objects, data objects, etc.).

Compile and transfer
To compile the example program and transfer it to User RAM, ...
... click on the

button in the toolbar, or

... select the Transfer to Target command from the Project menu.
Using this command, the entire project is compiled and then the objects are
transferred to the defined memory area and started.
The progress and completion status of the compile procedure is shown in the
message window:
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To avoid errors, B&R Automation Studio™ checks the structure of the target system
hardware, the version of the operating system and all previously installed software
objects during transfer. Known problems will be clearly pointed out so that additional
errors can be avoided.
The following message is given after the project has been successfully transferred:

The example program is now running in User RAM. The digital output is set or reset
according to the logical state of the digital input.
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Testing the object
B&R Automation Studio™ recognizes many problems during programming and
indicates them using compiler messages, however it is necessary to have a
comfortable debugger for large projects. Therefore powerful diagnostics tools are
integrated in B&R Automation Studio™.

LAD monitor
With the Ladder Diagram Monitor (LAD monitor), it is possible show and force
process variables from a ladder diagram running on the controller directly in the
ladder diagram mask.
To open the LAD Monitor, you have to first open the LAD Editor. To do this,
double−click on the symbol for example program "logic1" in the software
configuration. You can then open the LAD monitor from the LAD editor by ...
... clicking on

in the toolbar, or

... entering the key combination CTRL+M, or
... selecting the Monitor command in the View menu.
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Forcing a Variable
Using the Force function in the LAD monitor, you can change the state of digital
inputs from B&R Automation Studio™. This function can be used to test the
example program "logic1".

If a process variable is forced, it is assigned a specific value and remains at
this value. If an object writes to a forced process variable, the changed value
is only valid for the current cycle. Then the variable is overwritten with the
force value entered.
The Force Function is also available in other B&R Automation Studio™
diagnostics tools.
To force the variable "key_1", click on the symbol for the digital input "key_1" with
the right mouse button and select Force from the context menu shown.
Then a dialog box is shown asking if the variable should be forced. Answer this
question with OK.
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A check mark to the left of the Force menu item in the shortcut menu
means that the variable is forced! The values of forced variables are also
shown in red in the LAD monitor.
Then you can set the value of the digital input "key_1" to 1, by ...
... clicking on the symbol for the digital input with the right mouse button again and
selecting Value from the context menu. The value "1" can now be entered. Press
ENTER to complete the entry.
... click on the symbol for the digital input and press the SPACEBAR. The value "1"
can now be entered. Press ENTER to complete the entry.
This causes the digital output "relay_1" to be set:
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Closing the LAD Monitor
Close the LAD monitor by ...
... clicking on Exit in the File menu, or
... clicking on

in the upper right corner of the LAD monitor window.

Additional information concerning "LAD Monitor" can be found in the B&R
Automation Studio™ online help.

System monitor
When you close the LAD monitor window, B&R Automation Studio™ remains in
monitor mode. The System Monitor (System Monitor = software configuration in
monitor mode) is shown:

To turn monitor mode on or off, ...
... click on the
58
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... enter the key combination CTRL + M, or
... select the Monitor command from the View menu.
Different information is shown in the software configuration depending on if B&R
Automation Studio™ is in monitor mode or not.

Monitor Mode Turned Off
In this mode, all objects in the current project are shown. Objects only found on the
controller are not shown in this mode. The following information is shown in the right
section of the project window:

Column

Description

Module name Symbol and name of the software object.
Version
Transfer to
Size (bytes)

Version number of the software object.
Target memory for the software object (valid for
the next transfer).
Size of the compiled software object in bytes. If the
object has not been compiled, the value 0 is
shown.
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Monitor Mode Turned On
In this view, the differences between the current project (computer) and the
controller are shown. The following information is provided in addition to the symbol
and name of an object:

Column
Description
Module Name Symbol and name of the software object.
Target vs. Project Objects in the project and on the controller are compared and
the result is shown:

Location
State

• on target only..........Object is only on the controller
(target system).
• not on target...........Object is not on the controller (only
in project).
• older on target ........Object in the project is more
current than the one on the controller.
• newer on target ......Object on the controller is more
current than the one in the project.
• equal......................Object in the project and on the
controller are identical.
Memory where the object can be found on the controller.
State of the object.
The status of cyclic objects (cyclic objects, timer objects,
interrupt and exception objects) and idle time objects:
• RUN
Software object being executed.
• STOP
Software object stopped (NOT being executed).
The status of the system and data objects:
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• RDY
The software object (system or data object) is ready to
be used by other objects.
• USE
The software object (system or data object) is being
used by other objects.

Additional information concerning "System Monitor" can be found in the B&R
Automation Studio™ online help.

Watch
Using the Watch Function, you can view, monitor and change the values of process
variables found on the controller. Open the watch window for the object "logic1" by...
... clicking on the symbol "logic1" in the software configuration and selecting the
Watch command in the Open menu, or
... clicking on the symbol "logic1" with the right mouse button in the software
configuration and selecting the Watch command from the context menu shown.
The following information is shown in the watch window:
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Column
Name
Type

Scope

Description
Names of process variables are shown in this column.
The data type of each variable is shown in this column.
The data type defines the memory requirements and value
range for a process variable (detailed information can be found
in the online help).
The user can define the scope of the variable in a drop down
box. The scope is predefined as global in the global editor.
The declaration can be called in such a way that it relates only
to an object. Only variables used within this object are
displayed. For objects the scope of variables can also be
defined as local. An object−specific declaration is called if ...
• ... the editor of an object is open and the window is in
the foreground (e.g. LAD editor open).
• ... an object (e.g. LAD object) is selected in the software
configuration.
The drop down box is called by double−clicking or by pressing
the spacebar.
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Force

Use the mouse or cursor keys to make the selection.
The following information is shown in this column:
Force
Symbol Description Status
Force
symbol for
not
input
active
(green)
Force
symbol for
active
input
(green)
Force
not
symbol for
active
output (red)
Force
symbol for
output (red)
No
Variable in
Symbol memory

Value

active

−−

The value of variables is shown in this column. You can select
from several view formats:
• binary
• octal
• decimal
• hexadecimal
• string
The commands Binary, Octal, Decimal, Hexadecimal and String
in the View menu and in the shortcut menu for the watch
window (called with the right mouse button in the watch
window) can be used to select the view format. A dot • to the left
of the menu item means that the variable values will be
displayed in this format.

Inserting a Variable
All functions in the watch window refer to the software object that was marked in the
software configuration when the watch function was called. That means you can
only insert variables that exist in the selected object.
You can insert a variable in the watch window as follows:
• The watch window has to be the active window!
• Insert a new variable by...
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... clicking on

in the toolbar, or

... pressing INS and then the SPACEBAR, or
... clicking on Variable in the Insert menu, or
... clicking in the watch window with the right mouse button and
select the Insert Variable command in the context menu shown.
• Select the desired variable (e.g. "key_1") in the Insert Watch dialog box and
click then press the Add button.
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You can also select several variable at the same time in the Insert Watch dialog box
and insert them into the watch window. To do this, press and hold SHIFT when
selecting the variables (with the mouse or CURSOR key):

After closing the dialog box by pressing the Add button, all marked variables are
inserted into the watch window:
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Editing a Variable
You can change the value of a variable as follows:
• Mark a variable in the watch window.
• Change the value of this variable by ...
... pressing the SPACEBAR (the cursor has to be in the Value column) and entering
the desired value, or
... clicking on Variable in the Edit menu and entering the desired value, or
... entering the desired value directly (the cursor has to be in the Value column).
• Press ENTER to accept the new value or ESC to disregard the change.

If the variable to be changed is an input or output as with our example
(digital input "key_1" or digital output "relay_1"), the variable is
automatically forced after acknowledgement.
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Activating/Deactivating Force Status
The force status of a variable can be activated manually.
To activate the force status of a variable, mark the variable in the Watch window
and ...
... click on the

button in the toolbar, or

... click on Force in the Object menu or
... click on Force in the shortcut menu (called with the right mouse button)
Then a dialog box is shown asking if the variable should be forced. Answer this
question with OK..

A check mark to the left of the Force menu item in the Object menu and in
the shortcut menu means that the variable is forced! The following
symbols in the Force column of the watch window also indicate a forced
variable:

Symbol

Description
Force symbol
for input
(green)
Force symbol
for output (red)
active

Force
Status
active

active

To deactivate the force status of a variable, mark it in the watch window and click
on Force again in the Object menu or shortcut menu (called with the right mouse
button). Then a dialog box is shown asking if the process variable should be forced.
Answer this question with OK.
If you want to deactivate the force status of all variables in the watch window at the
same time, click on the
button in the toolbar or on Force All Off in the Object
menu.
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Closing the Watch Window
Close the watch window by ...
... clicking on Exit in the File menu, or
... clicking on

in the upper right corner of the watch window.

Additional information concerning all functions of the watch window can be found in
the B&R Automation Studio™ online help.
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Appendix A − Frequently Asked Question
How to install the operating system?
The B&R Automation Runtime™ operating system is stored in System ROM on the
processor (CPU or PP).

System ROM is a nonvolatile memory area in the form of a Flash PROM.

You can download or update the B&R Automation Runtime™ operating system
yourself using B&R Automation Studio™.
The operating system download or update is described for each module
in the respective hardware user’s manual. You can also look in the
module description integrated in B&R Automation Studio™.
Please note the switch settings for bootstrap loader mode or RUN mode
listed there.

Processors with application memory
Application memory is always delivered without an operating system installed. The
first operating system installation (operating system download) can be carried out as
follows for processors with application memory (B&R SYSTEM 2010 CPUs CP10x
and CP200/CP210):
1. Turn off power to the controller. This is necessary because the application
memory is only allowed to be removed or inserted without power applied!
2. Insert new Flash PROM application memory and return power.
Make sure that the write protect switch on the front of the application memory is on
the write position!
3. Take the online cable and connect the computer to the CPU where the operating
system should be installed.
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4. Start B&R Automation Studio™.

5. Then open a project in B&R Automation Studio™. To do this, select Open
Project... from the File menu.
6. Start the download procedure by calling the Services command from the Project
menu. Select
Transfer Operating System... from the menu shown.

7. B&R Automation Studio™ now gathers all information required for the operating
system download (type and revision of the application memory, etc.) from the
controller. Then a dialog box will be opened where you can define a few CAN
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parameters (baud rate, CAN identifier and CAN node number):

8. The default settings in this dialog box only has to changed if your controller is in a
CAN network that requires other settings!
9. Selecting the "<Back" button causes a dialog box to be shown where you can
select the interface used on your computer for the connection to the target system
(e.g. COM2) and the desired operating system version (e.g. V2.28).
With "Next>", you can return to the dialog box used to define the CAN parameters.
The dialog box used to define the interface and the operating system version can
also be shown first. This is the case if e.g. an connection is not made. The
respective PC interface can then be selected. Afterwards the operating system has
to be selected in the BR Automation System directory (abbr.
...\AS\System\V0228\m68k). The connection to the target will be carried out
automatically and the CAN properties dialog opens.

10. After closing the CAN parameter dialog box by pressing "Next>", the Flash
PROM is deleted. Then the selected version of the operating system is downloaded
to Flash PROM. Download progress is shown on the screen. The download
procedure can take a few minutes!
11. The controller is now ready for operation.

Appendix A − Frequently Asked Question

71

B&R Automation Studio Quick Start

If the update procedure is interrupted, the installation of the operating
system has to be started again.

Processors without application memory
An operating system is already installed during delivery for processors without
application memory (CP260, CP360, IF260, IP161, XP152, CP430, CP47x, CP77x,
AR102, AR105, ARxxx).
Updating the operating system is only possible in RUN Mode. The RUN Mode
settings can be found in the hardware documentation. The following steps are
necessary for an operating system update:
1. Take the online cable and connect the computer to the processor (CPU or PP)
where the operating system should be updated.

2. Start B&R Automation Studio™.
3. Then open a project in B&R Automation Studio™. To do this, select Open
Project... from the File menu.
4. Start the download procedure by calling the Services command from the Project
menu. Select Transfer Operating System... from the menu shown.
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5. B&R Automation Studio™ now gathers all information required for the operating
system download (type and revision of the processor module, etc.) from the
controller. Then a dialog box will be opened where you can define a few CAN
parameters (baud rate, CAN identifier and CAN node number):

6. The default settings in this dialog box only has to changed if your controller is in a
CAN network that requires other settings!

Appendix A − Frequently Asked Question

73

B&R Automation Studio Quick Start
7. Selecting the "<Back" button causes a dialog box to be shown where you can
select the desired operating system version (e.g. V2.25). With "Next>", you can
return to the dialog box used to define the CAN parameters.
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8. After closing the CAN parameter dialog box by pressing Next, the Flash PROM is
deleted. Then the selected version of the operating system is downloaded to Flash
PROM. Download progress is shown on the screen. The download procedure can
take a few minutes!
9. The controller is now ready for operation.

If the update procedure is interrupted, the installation of the operating
system has to be started again.
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How can I work without hardware?
B&R Automation Studio™ is a hardware oriented programming system. That
means the hardware has to be defined when creating a project. We differentiate
between Automatic Hardware Recognition and Manual Hardware Definition.
If you want to work without hardware, you have to use manual hardware definition
when creating a project.

Manual hardware definition
A detailed description of the steps required for manual hardware definition can be
found in (see "Chapter 3 −> How to create a project −> Creating a New Project").
If the target system hardware is not available, the programming device can work
OFFLINE (no connection between computer and controller).

Define additional modules
After creating a project, additional modules can be defined in the left section of the
project window (e.g. digital or analog I/O modules). This is done as follows:
• In the hardware configuration, place the cursor on the position where you
want to insert the module.
• Insert a new module by...
... clicking on Module… in the Insert menu, or
... pressing the INS key.
• Select the desired module in the Select Module dialog box.
• Acknowledge your selection by pressing the OK button.
You can create any hardware configuration by simply repeating this procedures for
all desired modules. Then you can declare variables, create objects, etc.
Take note that you can program a project without hardware, but you can't
test it!
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Is multiple installation of B&R Automation Studio
possible?
Multiple installation of B&R Automation Studio is possible beginning with V2.2.
Changing to different versions takes place by using the Version Changer. However,
only one version at a time can be active.
Older B&R Automation Studio versions have had their installation programs
modified (as far back as V1.4.1) so that they can also be installed alongside newer
versions.

Installing the Version Changer
The Version Changer must be installed on your system before it can be selected
from the Start Menu. To do this, run 'BrMenu.exe' from the root directory of your
installation CD.
The following dialog box opens:

Select 'Automation Studio Version Changer' and begin the installation procedure by
clicking on the 'Start' button.
Menus will lead you through the installation process. If installation is successful,
then the Version Changer is displayed under 'B&R Automation' in the Start Menu.

Switching Procedure
If several versions are installed at one time, the Version Changer can be used to
switch between them.
Start the Version Changer from the Start Menu:
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The dialog box which appears displays the active version by highlighting it. The
up/down cursor keys can be used to highlight the version which should now be
used. Pressing the 'Change Version' switches the highlighted version active. This
process can take a few seconds.

The 'Exit' button can be used to leave this dialog box.
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Key combinations for command calls
Key
Combinations
General

Description

+/−

Trees can be opened and closed using the + and – keys on the
number block. As an alternative to the number block keys,
CTRL+− and CTRL++ can be used on the normal keyboard.

ENTER

Opens the respective editor in the software configuration or
closes the dialog box using the highlighted button (mostly OK).

ALT+ENTER

With ALT+ENTER, you can enter the respective properties
dialog box.

ESC

Cancels entries and dialog boxes.

F1

Opens context sensitive help.

F4

Open selection boxes (e.g. selection box for task class in the
properties dialog box for tasks).

CTRL+F4

Close current editor window.

ALT+F4

Close B&R Automation Studio™.

F6

Switch between left and right panes of the project window.

CTRL+F6

Switch between the individual editor windows, as alternative to
CTRL+TAB.
SHIFT+CTRL+F6 Like CTRL+F6 but in then other direction, as alternative to
SHIFT+CTRL+TAB.
SHIFT+F10
Opens the respective shortcut menu (like the right mouse
button), SHORTCUT KEY can also be used (to the left of the
right CTRL KEY on a Win95 keyboard).
ALT+SPACEBAR Opens the system menu in the AS window.
ALT+−

Opens the system menu in the respective editor window.

INS

Inserts a new element in a table, the new element is inserted
above the current cursor position.
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CTRL+INS

If several hierarchies of elements exist in a table or an editor
(main and sub−elements), the main elements are to be created
with CTRL+INS and the sub−elements with INS. If the cursor is
on a main element, the sub−element is inserted as the last
element in the list below the main element.

DEL

Deletes the currently marked object.

SPACEBAR

With the SPACEBAR, the currently marked cell in a table goes
into entry mode. In a cell that is already in entry mode, the
SPACEBAR in is used to go to a selection dialog box (if
available).

CTRL+D

Disables the object currently marked by the cursor.

CTRL+R

Target memory of the software object is User RAM.

CTRL+U

Target memory of the software object is User ROM.

CTRL+I

Target memory of the software object is FIX RAM.

CTRL+E

Target memory of the software object is a MEM Card.

CTRL+T

Target memory of the software object is SYSTEM ROM.

CTRL+X

Cut the currently marked block to the clipboard.

CTRL+C

Copy the currently marked block to the clipboard.

CTRL+V

Paste a block from the clipboard.

CTRL+Z

Undo the last action.

CTRL+Y

Redo the last undo action.

CTRL+S

Save

CTRL+P

Print

CTRL+F

Calls the Find dialog box.

CTRL+H

Calls the Replace dialog box.
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CTRL+G

Calls the Goto function.

CTRL+W

Opens the PV Monitor.

Desktop
CTRL+O

Open a project.

CTRL+N

Create a new project.

CTRL+M

Activates monitor mode.

ALT+0

Switches to the project window.

ALT+1

Places focus on the message window (docked under the main
window).
Jumps to the next message in the message window. Either the
next error message or the next result from "Edit −> Find in
Files" depending on which register is active in the message
window.
Jumps to the previous message in the message window.

F4

SHIFT+F4
Text Editors
F3

Continue search in the forward direction.

SHIFT+F3

Continue search in the reverse direction.

Build & Transfer
CTRL+F5

Transfer to PCC.

F7

Build

CTRL+F7

Build all

Debugger
F5

Continue

SHIFT+F5

Cancel Debugger, allow task to continue.

F9

Set breakpoint
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SHIFT+F9

Show breakpoint

F11

Step into

F10

Step over

LAD Editor
Key combinations for LAD editor can be found in the toolbar quick info or next to
the menu items.
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